Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Devstack (Havana) - curl SSL Certification verification error

I am trying to install devstack on Ubuntu 12.04 LTS but ran into this problem. The problem is "Curl SSL Certification error" I tried to solve problem with steps mentioned here -> http://curl.haxx.se/docs/sslcerts.html But I am not able to resolve this issue.

Please help me to resolve this issue.

  • sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= no_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes purge python-pip Reading package lists... Done Building dependency tree Reading state information... Done Package python-pip is not installed, so not removed 0 upgraded, 0 newly installed, 0 to remove and 629 not upgraded.
  • [[ 0 == \1 ]]
  • install_pip_tarball
  • cd /home/user/OpenStack/devstack/files
  • curl -O https://pypi.python.org/packages/source/p/pip/pip-1.4.1.tar.gz % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:04 --:--:-- 0curl: (60) SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle" of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn't adequate, you can specify an alternate file using the --cacert option. If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL). If you'd like to turn off curl's verification of the certificate, use the -k (or --insecure) option.

Devstack (Havana) - curl SSL Certification verification error

I am trying to install devstack on Ubuntu 12.04 LTS but ran into this problem. The problem is "Curl SSL Certification error" I tried to solve problem with steps mentioned here -> http://curl.haxx.se/docs/sslcerts.html But I am not able to resolve this issue.

Please help me to resolve this issue.

  • + sudo DEBIAN_FRONTEND=noninteractive http_proxy= https_proxy= no_proxy= apt-get --option Dpkg::Options::=--force-confold --assume-yes purge python-pip
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package python-pip is not installed, so not removed
    0 upgraded, 0 newly installed, 0 to remove and 629 not upgraded.
  • upgraded. + [[ 0 == \1 ]]
  • install_pip_tarball
  • ]] + install_pip_tarball + cd /home/user/OpenStack/devstack/files
  • /home/user/OpenStack/devstack/files + curl -O https://pypi.python.org/packages/source/p/pip/pip-1.4.1.tar.gz % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:04 --:--:-- 0curl: (60) SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed More details here: http://curl.haxx.se/docs/sslcerts.html

http://curl.haxx.se/docs/sslcerts.html curl performs SSL certificate verification by default, using a "bundle" of Certificate Authority (CA) public keys (CA certs). If the default bundle file isn't adequate, you can specify an alternate file using the --cacert option. If this HTTPS server uses a certificate signed by a CA represented in the bundle, the certificate verification probably failed due to a problem with the certificate (it might be expired, or the name might not match the domain name in the URL). If you'd like to turn off curl's verification of the certificate, use the -k (or --insecure) option.

option.