Revision history [back]

click to hide/show revision 1
initial version

Queens Octavia Endpoint

I'm trying to setup Octavia in my Queens OpenStack deploy. I've setup the Octavia service and have it running. Now I am attempting to create the Octavia endpoint in keystone. Based on this bug: https://bugs.launchpad.net/heat/+bug/1737567 I should be able to, however whenever I try, I get the following error:

# openstack endpoint create --region RegionOne load-balancer public http://cumulonimbus.asgard.int:9876
No service with a type, name or ID of 'load-balancer' exists.
# openstack endpoint create --region RegionOne octavia public http://cumulonimbus.asgard.int:9876
No service with a type, name or ID of 'octavia' exists.

Based on this question I should be able to create the service: https://ask.openstack.org/en/question/116031/solvedpikeoctavia-cannot-create-lb-from-horizon/ Despite the documentation never mentioning to do it in the first place. Additionally the documentation still says you need the neutron LBaaS configured and according to this: https://ask.openstack.org/en/question/113466/octavia-lbaasv2-driver-error/?answer=113469#post-id-113469 You don't need it and can do pure Octavia. What am I missing that Keystone doesn't recognize Octavia as a service?

Queens Octavia Endpoint

I'm trying to setup Octavia in my Queens OpenStack deploy. I've setup the Octavia service and have it running. Now I am attempting to create the Octavia endpoint in keystone. Based on this bug: https://bugs.launchpad.net/heat/+bug/1737567 https://bugs.launchpad.net/heat/+bug/1737567 I should be able to, however whenever I try, I get the following error:

# openstack endpoint create --region RegionOne load-balancer public http://cumulonimbus.asgard.int:9876
No service with a type, name or ID of 'load-balancer' exists.
# openstack endpoint create --region RegionOne octavia public http://cumulonimbus.asgard.int:9876
No service with a type, name or ID of 'octavia' exists.

Based on this question I should be able to create the service: https://ask.openstack.org/en/question/116031/solvedpikeoctavia-cannot-create-lb-from-horizon/ https://ask.openstack.org/en/question/116031/solvedpikeoctavia-cannot-create-lb-from-horizon/

Despite the documentation never mentioning to do it in the first place. Additionally the documentation still says you need the neutron LBaaS configured and according to this: https://ask.openstack.org/en/question/113466/octavia-lbaasv2-driver-error/?answer=113469#post-id-113469 https://ask.openstack.org/en/question/113466/octavia-lbaasv2-driver-error/?answer=113469#post-id-113469

You don't need it and can do pure Octavia. What am I missing that Keystone doesn't recognize Octavia as a service?