Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

HOST_IP change in OpenStack Pike, cannot log into Dashboard

Hello. I have installed openstack pike on my local machine using devstack. I have downloaded Ubuntu 16.04 OS and then followed the procedure. Downloaded devstack, specified the necessary elements and HOST_IP in the local.conf and hit ./stack.sh. Everything worked.

Unfortunately now I am in another network and using another IP for the host. I have researched on google how to change IP, but nothing worked and I cannot log into the Openstack Dashboard. I have looked in keystone log and see that it still uses the old IP. I have changed the IP in the database, re-run ./stack.sh. Nothing works. Of course, I didn't found any resolution for OpenStack Pike. All the resolutions used rejoin-stack.sh, which is no longer present in my version.

Please, what are the steps that I need to use, for my OpenStack distribution, to be able to access the environment if I change network and implicitly the IP.

Thank you and I really hope that you can help me. Silviu