Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Block Device Mapping is Invalid: failed to get image

My network setup is as follows: Controller node @10.0.0.1, 192.168.2.100 (ip tables NAT set up on controller to give management network internet) Compute node @ 10.0.0.2 (connected to the provider network 192.168.2.1/23, but only access for vm's)

Followed the default install guide, creating a tier 2 network, set up cinder as follows:

  • Controller node running the standard controller setup, as per default instructions on installation guide
  • Compute node running a cinder node setup with both LVM and NFS, Using the command line I can create images just fine.

When I use the Horizion WebUI to make a basic VM, I get the following error:

Block Device Mapping is Invalid: failed to get image 9d1e61c7-c490-403a-ace1-019c46da2cf4. (HTTP 400) (Request-ID: req-b118e8b2-54ef-4f98-8b44-deb5aa99600a)

Logs:

Cinder API@controller: http://paste.openstack.org/show/734098/

Cinder Scheduler@controller: http://paste.openstack.org/show/734097/

Cinder Volume@compute node: http://paste.openstack.org/show/734095/

Please let me know if you need anymore information / any more logs, and thankyou for your time.

(Edit, noticed the log pastes had been cut off, I assume there is some kind of max limit to openstack's pastebin, so I've made new pastes that show only the last couple days of log messages)

Block Device Mapping is Invalid: failed to get image

My network setup is as follows: Controller node @10.0.0.1, 192.168.2.100 (ip tables NAT set up on controller to give management network internet) Compute node @ 10.0.0.2 (connected to the provider network 192.168.2.1/23, but only access for vm's)

Followed the default install guide, creating a tier 2 network, set up cinder as follows:

  • Controller node running the standard controller setup, as per default instructions on installation guide
  • Compute node running a cinder node setup with both LVM and NFS, Using the command line I can create images just fine.

When I use the Horizion WebUI to make a basic VM, I get the following error:

Block Device Mapping is Invalid: failed to get image 9d1e61c7-c490-403a-ace1-019c46da2cf4. (HTTP 400) (Request-ID: req-b118e8b2-54ef-4f98-8b44-deb5aa99600a)

Logs:

Cinder API@controller: http://paste.openstack.org/show/734098/

Cinder Scheduler@controller: http://paste.openstack.org/show/734097/

Cinder Volume@compute node: http://paste.openstack.org/show/734095/

Please let me know if you need anymore information / any more logs, and thankyou for your time.

(Edit, noticed the log pastes had been cut off, I assume there is some kind of max limit to openstack's pastebin, so I've made new pastes that show only the last couple days of log messages)

(Edit 2, more logs)

glance/registry.log http://paste.openstack.org/show/734106/

glance/api.log http://paste.openstack.org/show/734107/

nova/nova-api.log http://paste.openstack.org/show/734108/

nova/nova-conductor.log http://paste.openstack.org/show/734109/

nova/nova-manage.log http://paste.openstack.org/show/734110/

nova/nova-scheduler.log http://paste.openstack.org/show/734111/

nova/nova-compute.log http://paste.openstack.org/show/734112/