Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ongoing problem with starting neutron-server on Fedora 20 (RDO Havana)

In previous successful attempt  setting up  two node Neutron+GRE+OVS‏  

[following Kashyap directions](http://kashyapc.fedorapeople.org/virt/openstack/Two-node-Havana-setup.txt)

on real F20 boxes I was able to start neutron-server with ( using native F20 repos)   with  plugin.ini

[root@dfw02 neutron(keystone_admin)]$ cat plugin.ini | grep -v ^# | grep -v ^$
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.1.127
[agent]
[securitygroup]
[DATABASE]
sql_connection = mysql://root:password@dfw02.localdomain/ovs_neutron
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

and finally

[root@dfw02 ~]# ovs-vsctl show
7d78d536-3612-416e-bce6-24605088212f
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-ex
        Port "p37p1"
            Interface "p37p1"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-2"
            Interface "gre-2"
                type: gre
                options: {in_key=flow, local_ip="192.168.1.127", out_key=flow, remote_ip="192.168.1.137"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.0.0"

Compute node instances were able to obtain floating and internal ip addresses I am running this TwoNode Cluster in mean time with all yum updates after 01/23/2014

In new attempt on fresh F20 instance Neutron-server may be started only with plugin.ini contains sql_connection as follows :

[DATABASE]
sql_connection = mysql://root:password@localhost/ovs_neutron

Block like :-

Port "gre-2"
            Interface "gre-2"
                type: gre
                options: {in_key=flow, local_ip="192.168.1.147", out_key=flow, remote_ip="192.168.1.157"}

doesn't appear in `ovs-vsctl show` output  . Nothing works on Compute all Configs are the the same as in first attempt.

The error from mysql, which I get "Access denied fror 'root"@'new_hostname' new_hostname as before is in /etc/hosts

192.168.1.147 new_hostname.localdomain new_hostname

and in /etc/hostname new_hostname.localdomain

For me it looks like bug for neutron-server to be bind to 127.0.0.1 ,actually, connected with MariaDB database.

I did 2 attempts to reproduce it from scratch building Controller and every time Neutron-server start up limitation came up.

On compute node  192.168.1.137 :-

[root@dfw01 neutron]# cat plugin.ini
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.1.137
[agent]
[securitygroup]
[DATABASE]
sql_connection = mysql://root:password@192.168.1.127/ovs_neutron
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

It cannot work any longer affecting neutron-openvswitch service on compute node

Ongoing problem with starting neutron-server on Fedora 20 (RDO Havana)

In previous successful attempt  setting up  two node Neutron+GRE+OVS‏  

[following Kashyap directions](http://kashyapc.fedorapeople.org/virt/openstack/Two-node-Havana-setup.txt)

on real F20 boxes I was able to start neutron-server with ( using native F20 repos)   with  plugin.ini

[root@dfw02 neutron(keystone_admin)]$ cat plugin.ini | grep -v ^# | grep -v ^$
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.1.127
[agent]
[securitygroup]
[DATABASE]
sql_connection = mysql://root:password@dfw02.localdomain/ovs_neutron
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

and finally

[root@dfw02 ~]# ovs-vsctl show
7d78d536-3612-416e-bce6-24605088212f
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-ex
        Port "p37p1"
            Interface "p37p1"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-2"
            Interface "gre-2"
                type: gre
                options: {in_key=flow, local_ip="192.168.1.127", out_key=flow, remote_ip="192.168.1.137"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.0.0"

Compute node instances were able to obtain floating and internal ip addresses I am running this TwoNode Cluster in mean time with all yum updates after 01/23/2014

In new attempt on fresh F20 instance Neutron-server may be started only with plugin.ini contains sql_connection as follows :

[DATABASE]
sql_connection = mysql://root:password@localhost/ovs_neutron

Block like :-

Port "gre-2"
            Interface "gre-2"
                type: gre
                options: {in_key=flow, local_ip="192.168.1.147", out_key=flow, remote_ip="192.168.1.157"}

doesn't appear in `ovs-vsctl show` output  . Nothing works on Compute all Configs are the the same as in first attempt.

The error from mysql, which I get "Access denied fror 'root"@'new_hostname' new_hostname as before is in /etc/hosts

192.168.1.147 new_hostname.localdomain new_hostname

and in /etc/hostname new_hostname.localdomain

For me it looks like bug for neutron-server to be bind to 127.0.0.1 ,actually, connected with MariaDB database.

I did 2 attempts to reproduce it from scratch building Controller and every time Neutron-server start up limitation came up.

On compute node  192.168.1.137 :-

[root@dfw01 neutron]# cat plugin.ini
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.168.1.137
[agent]
[securitygroup]
[DATABASE]
sql_connection = mysql://root:password@192.168.1.127/ovs_neutron
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

It cannot work any longer affecting neutron-openvswitch service on compute node

Per Original docs

On Controller

2. (OVS) plugin.ini

$ cat /etc/neutron/plugin.ini | grep -v ^$ | grep -v ^#
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.169.142.49
[agent]
[securitygroup]
[DATABASE]
sql_connection = mysql://neutron:fedora@node1-controller/ovs_neutron
sql_max_retries=10
reconnect_interval=2
sql_idle_timeout=3600
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

On Compute

2. (OVS) plugin.ini

$ cat plugin.ini | grep -v ^$ | grep -v ^#
[ovs]
tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun
local_ip = 192.169.142.57
[DATABASE]
sql_connection = mysql://neutron:fedora@node1-controller/ovs_neutron
[SECURITYGROUP]
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[agent]
[securitygroup]

I believe it won't work on current status of Fedora 20 with native Havana packages