Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

OpenSource Mano and Openstack: 503 Service Unavailable

Hello,

I am trying to configure Openstack and Open Source Mano to make them work together. I'm following the tutorial (OSM Release 4). I have a problem at the step "Instantiating a NS". After clicking on Launch, I’ve got the following message:

ERROR Creating ns at RO: b"---\nerror:\n code: 503\n description: 'VIM Exception vimconnConnectionException ConnectFailure: Unable\n to establish 
connection to http://10.0.0.11:5000/v3/auth/tokens: HTTPConnectionPool(host=''10.0.0.11'',\n port=5000): 
Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('': Failed to 
establish a new connection: [Errno 111]\n Connection refused'',)). (True, '' Rollback successful.'')'\n type: 503 Service Unavailable\n"

if I reach the url in the browser I get the following error:

error   
message "The request you have made requires authentication."
code 401
title "Unauthorized"

In another question it was suggested to insert "identity" in the url (http://10.0.0.11/identity/v3), I tried but it did not work I always get the same error

I created before the datacenter:


osm vim-create --name openstack-site --user admin --password userpwd --auth_url http://10.0.0.11:5000/v3 --tenant admin --account_type openstack --config='{security_groups: default, keypair: mykey}'
with the right parameters.
Thanks in advance