Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

installing glance, greenlet problem

Hi,

i'm using debian (7.0 a.k.a. wheezy). and was following your guide. At the part of installing the image service i ran into a problem. When trying to install glance it gave me an error, namely that it depends on glance-api and glance-registry, so i tried installing glance-common. Turns out this depends on python-glance so i tried installing that, and that's where the problem starts. This package depends on python-greenlet, which is installed but the error said: "depends: python-greenlet (>=0.3.2) but 0.3.1-2.5 is to be installed". now i've tried many things, apt-get update, upgrade, pip install greenlet, installing the dev version of greenlet and then some more minor things i've forgotten at the moment, but nothing seems to work. Does anyone have an idea how to fix this problem ?

I would be most grateful.