Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

TASK [os_glance : Ensure glance service] Error

Hello everyones,

I am deployment Openstack-ansible 17.0.7 about 3 nodes on virtualbox.

  • 1 controller or Infra1
  • 1 compute
  • 1 storage

In my case, Infra1 is the node to start all containers (haproxy, neutro, horizon, keyston, etc.)

when I am executing last yaml file (setup_openstack.ymal). I got the error below:

fatal: [infra1_glance_container-d3e38f26]: FAILED! => {"attempts": 100, "changed": false, "failed": true, "module_stderr": "mesg: ttyname failed: Inappropriate ioctl for device\nTraceback (most recent call last):\n File \"/tmp/ansible_13lCct/ansible_module_keystone.py\", line 1469, in <module>\n main()\n File \"/tmp/ansible_13lCct/ansible_module_keystone.py\", line 1463, in main\n km.command_router()\n File \"/tmp/ansible_13lCct/ansible_module_keystone.py\", line 487, in command_router\n facts = action(variables=action_command['variables'])\n File \"/tmp/ansible_13lCct/ansible_module_keystone.py\", line 1038, in ensure_service\n self._authenticate()\n File \"/tmp/ansible_13lCct/ansible_module_keystone.py\", line 614, in _authenticate\n client_args)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneclient/client.py\", line 62, in Client\n d = discover.Discover(session=session, *kwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneclient/discover.py\", line 178, in __init__\n authenticated=authenticated)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneclient/_discover.py\", line 143, in __init__\n authenticated=authenticated)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneclient/_discover.py\", line 38, in get_version_data\n resp = session.get(url, headers=headers, authenticated=authenticated)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 840, in get\n return self.request(url, 'GET', *kwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 573, in request\n auth_headers = self.get_auth_headers(auth)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 900, in get_auth_headers\n return auth.get_headers(self, *kwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/plugin.py\", line 95, in get_headers\n token = self.get_token(session)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/identity/base.py\", line 88, in get_token\n return self.get_access(session).auth_token\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/identity/base.py\", line 134, in get_access\n self.auth_ref = self.get_auth_ref(session)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/identity/v3/base.py\", line 177, in get_auth_ref\n authenticated=False, log=False, *rkwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 848, in post\n return self.request(url, 'POST', **kwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 698, in request\n resp = send(kwargs)\n File \"/usr/local/lib/python2.7/dist-packages/keystoneauth1/session.py\", line 772, in _send_request\n raise exceptions.ConnectFailure(msg)\nkeystoneauth1.exceptions.connection.ConnectFailure: Unable to establish connection to http://10.9.8.28:35357/v3/auth/tokens: ('Connection aborted.', BadStatusLine(\"''\",))\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 1}

In another post with the same bug, no solved the problem. If people want more information about my config file, I will respond with information.

Thank very much. best regard.