Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Error appeared during Puppet run: IP_prescript.pp

Hello guys, I am new to OpenStack. I have been trying to install OpenStack on RHEL 6.5 following RDO quick start guide. It would be really helpful if you help me workaround this problem. Thanks. I am getting the above mentioned error while doing packstack --allinone If i need to provide any other details, please let me know Here is the terminal output:

Adding Swift common manifest entries...                [ DONE ]
Adding Provisioning manifest entries...                [ DONE ]
Adding Ceilometer manifest entries...                  [ DONE ]
Adding Ceilometer Keystone manifest entries...         [ DONE ]
Adding Nagios server manifest entries...               [ DONE ]
Adding Nagios host manifest entries...                 [ DONE ]
Adding post install manifest entries...                [ DONE ]
Preparing servers...                                   [ DONE ]
Installing Dependencies...                             [ DONE ]
Copying Puppet modules and manifests...                [ DONE ]
Applying Puppet manifests...
Applying 10.106.233.145_prescript.pp
                                                                                               [ ERROR ]

ERROR : Error appeared during Puppet run: 10.106.233.145_prescript.pp
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
You will find full trace in log /var/tmp/packstack/20140206-102302-VH1aCT/manifests/10.106.233.145_prescript.pp.log
Please check log file /var/tmp/packstack/20140206-102302-VH1aCT/openstack-setup.log for more information

HERE iS THE ERROR LOG prescript.pp.log

Notice: Compiled catalog for cspg-tpi-os.cisco.com in environment production in 0.43 seconds
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: Loaded plugins: priorities, product-id, refresh-packagekit, rhnplugin, security,
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:               : subscription-manager
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: This system is receiving updates from Red Hat Subscription Management.
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: This system is receiving updates from RHN Classic or RHN Satellite.
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
Error: yum update -y kernel iputils iproute returned 1 instead of one of [0]
Error: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: change from notrun to 0 failed: yum update -y kernel iputils iproute returned 1 instead of one of [0]
Notice: /Stage[main]/Packstack::Netns/Notify[packstack_info]: Dependency Exec[netns_dependecy_install] has failures: true
Warning: /Stage[main]/Packstack::Netns/Notify[packstack_info]: Skipping because of failed dependencies
Notice: Finished catalog run in 25.74 seconds