Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't deploy and instance. Image not found

This is a conjure-up openstack-lxd (queens) deployment on a fresh Ubuntu 18.04 physical server w/ Intel CoreI7 (6 cores) and 64 GB RAM. The conjure-up deployment runs fine with no errors and juju status shows everything up and running with no problems.

In the dashboard I can do just about everything, create networks, users, domains, projects, etc but I can't deploy an instance. The nova-compute log shows Instance failed to spawn: ImageNotFound: Image could not be found. followed by a stack trace (exception). The only other clue I found was in the glance-api log which shows a 404 error. Logs are attached. There are many successful api calls to glance so that appears to be available and working except for this 404. And the 404 seems to be causing the exception back on nova.

The dashboard lists the images correctly, and via the openstack CLI I can list the images and download them to a file. The images are the default trusty-lxd and xenial-lxd. I have also tried with cerros 0.4.0 but same problem.

I have tried conjure-up --classic, --classic --beta, and --classic edge, all produce exactly the same result.

I'm stumped. Any help or comments would be appreciated.

I apparently can't attach files yet so I'll try these links instead. Hopefully they will work.

https://www.dropbox.com/s/pcdd4hkvcpv1srk/nova-compute.log?dl=0 https://www.dropbox.com/s/dxqua6j8uocq0f7/glance-api.log?dl=0

Thanks!!!