Ask Your Question

Revision history [back]

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

What's going wrong ?

Thank you in advance

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

What's going wrong ?? I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Thank you in advance

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

Also neutron is not giving me replies:

[stack@ospd ~]$ neutron subnet-list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Gateway Timeout (HTTP 504)

What's going wrong ? ? It seems like I have some internal networking issue.

I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Thank you in advance

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

Also neutron is not giving me replies:

[stack@ospd ~]$ neutron subnet-list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Gateway Timeout (HTTP 504)

What's going wrong ? It seems like I have some internal networking issue.

I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Keystone log is telling me that the AMQP server is unreachable:

2018-06-10 04:25:39.295 2296 ERROR oslo.messaging._drivers.impl_rabbit [req-644091d9-2c81-47d2-a193-509baa6412ca - - - - -] [c1d8367b-b90c-4313-b0ad-7a7517c78b05] AMQP server on 192.168.126.1:5672 is unreachable: [Errno 111] Connection refused. Trying again in 32 seconds. Client port: None

Thank you in advance

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

Also neutron is not giving me replies:

[stack@ospd ~]$ neutron subnet-list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Gateway Timeout (HTTP 504)

What's going wrong ? It seems like I have some internal networking issue.

I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Keystone log is telling me that the AMQP server is unreachable:

2018-06-10 04:25:39.295 2296 ERROR oslo.messaging._drivers.impl_rabbit [req-644091d9-2c81-47d2-a193-509baa6412ca - - - - -] [c1d8367b-b90c-4313-b0ad-7a7517c78b05] AMQP server on 192.168.126.1:5672 is unreachable: [Errno 111] Connection refused. Trying again in 32 seconds. Client port: None

Rabbitmq server has issues with starting:

[root@ospd keystone]# systemctl status rabbitmq-server.service -l
● rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/rabbitmq-server.service.d
           └─limits.conf
   Active: failed (Result: exit-code) since sab 2018-06-09 14:04:53 EDT; 14h ago
  Process: 2418 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
  Process: 1280 ExecStart=/usr/lib/rabbitmq/bin/rabbitmq-server (code=exited, status=1/FAILURE)
 Main PID: 1280 (code=exited, status=1/FAILURE)

giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: attempted to contact: [rabbit@ospd]
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: rabbit@ospd:
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: * unable to connect to epmd (port 4369) on ospd: address (cannot connect to host/port)
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: current node details:
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - node name: 'rabbitmq-cli-39@ospd'
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - home dir: /var/lib/rabbitmq
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - cookie hash: dH8QUKHu937oTp5KhWw6Gw==
giu 09 14:04:53 ospd.lab.com systemd[1]: Failed to start RabbitMQ broker.
giu 09 14:04:53 ospd.lab.com systemd[1]: Unit rabbitmq-server.service entered failed state.
giu 09 14:04:53 ospd.lab.com systemd[1]: rabbitmq-server.service failed.

Thank you in advance

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

Also neutron is not giving me replies:

[stack@ospd ~]$ neutron subnet-list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Gateway Timeout (HTTP 504)

What's going wrong ? It seems like I have some internal networking issue.

I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Keystone log is telling me that the AMQP server is unreachable:

2018-06-10 04:25:39.295 2296 ERROR oslo.messaging._drivers.impl_rabbit [req-644091d9-2c81-47d2-a193-509baa6412ca - - - - -] [c1d8367b-b90c-4313-b0ad-7a7517c78b05] AMQP server on 192.168.126.1:5672 is unreachable: [Errno 111] Connection refused. Trying again in 32 seconds. Client port: None

Rabbitmq server has issues with starting:

[root@ospd keystone]# systemctl status rabbitmq-server.service -l
● rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/rabbitmq-server.service.d
           └─limits.conf
   Active: failed (Result: exit-code) since sab 2018-06-09 14:04:53 EDT; 14h ago
  Process: 2418 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
  Process: 1280 ExecStart=/usr/lib/rabbitmq/bin/rabbitmq-server (code=exited, status=1/FAILURE)
 Main PID: 1280 (code=exited, status=1/FAILURE)

giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: attempted to contact: [rabbit@ospd]
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: rabbit@ospd:
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: * unable to connect to epmd (port 4369) on ospd: address (cannot connect to host/port)
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: current node details:
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - node name: 'rabbitmq-cli-39@ospd'
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - home dir: /var/lib/rabbitmq
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: - cookie hash: dH8QUKHu937oTp5KhWw6Gw==
giu 09 14:04:53 ospd.lab.com systemd[1]: Failed to start RabbitMQ broker.
giu 09 14:04:53 ospd.lab.com systemd[1]: Unit rabbitmq-server.service entered failed state.
giu 09 14:04:53 ospd.lab.com systemd[1]: rabbitmq-server.service failed.

Thank you in advanceadvance.