Ask Your Question

Revision history [back]

LOCI image build gives No matching distribution found for enum-compat

Hi -

When attempting to build an OCI image using LOCI with:

docker build https://git.openstack.org/openstack/loci.git \
    --build-arg PROJECT=cinder \
    --build-arg FROM=ubuntu:xenial \
    --build-arg PROJECT_REF=stable/pike \
    --build-arg WHEELS=loci/requirements:master-ubuntu \
    --build-arg PROFILES="lvm" \
    --tag lvm-ubuntu-xenial-cinder:latest

I get the error:

Collecting networkx===1.11 (from -c /tmp/wheels/upper-constraints.txt (line 81))
  Downloading https://files.pythonhosted.org/packages/d3/2c/e473e54afc9fae58dfa97066ef6709a7e35a1dd1c28c5a3842989322be00/networkx-1.11-py2.py3-none-any.whl (1.3MB)
Collecting enum-compat (from eventlet===0.20.0->-c /tmp/wheels/upper-constraints.txt (line 135))
  Could not find a version that satisfies the requirement enum-compat (from eventlet===0.20.0->-c /tmp/wheels/upper-constraints.txt (line 135)) (from versions: )
No matching distribution found for enum-compat (from eventlet===0.20.0->-c /tmp/wheels/upper-constraints.txt (line 135))
The command '/bin/sh -c /opt/loci/scripts/install.sh' returned a non-zero code: 1

It appears to be some sort of issue with the loci-requirements image (https://hub.docker.com/r/loci/requirements/tags/) where it breaks at the exact same location for debian, ubuntu, and centos, but I am at a loss as to how to fix this, so any suggestions gratefully received.

Thanks, Piers.