Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

RDO Packstack Allinone Failed with getaddrinfo

Dear Team,

I have CentOS 7.4 Guest running on VMware .

I tried to install packstack --allinone on Guest OS using latest release Pike but it failed with following error many times. I disabled Networkmanager and firewall with SElinux set to Permissive mode. I also tried to install old Openstack releases but all failed with same reason.

ERROR : Error appeared during Puppet run: Error: Could not set 'present' on ensure: getaddrinfo: Name or service not known at /var/tmp/packstack/3a514fb425f843fdb16e31cc5d6e49b2/modules/packstack/manifests/provision/glance.pp:12 You will find full trace in log /var/tmp/packstack/20180219-135526-D7F8eL/manifests/ Please check log file /var/tmp/packstack/20180219-135526-D7F8eL/openstack-setup.log for more information Additional information: * A new answerfile was created in: /root/packstack-answers-20180219-135528.txt * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components. * File /root/keystonerc_admin has been created on OpenStack client host To use the command line tools you need to source the file. * To access the OpenStack Dashboard browse to . Please, find your login credentials stored in the keystonerc_admin in your home directory. * Note temporary directory /var/tmp/packstack/3a514fb425f843fdb16e31cc5d6e49b2 on host was not deleted for debugging purposes.

[root@openstack ~]# cat /etc/hosts localhost localhost.localdomain localhost4 localhost4.localdomain4 ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 openstack.lab openstack [root@openstack ~]# [root@openstack ~]# [root@openstack ~]# hostname openstack [root@openstack ~]# hostname -f openstack.lab [root@openstack ~]# is the static IP (OAM) of the interface for Guest operating system. When I open onenstack.lab from Firefox Browser on Guest & Host Operating system I am able to open the GUI.

Kindly suggest, what Should I do , I have also tried removing localhost lines from /etc/hosts but it did not worked.

Help would be really appreciated.