Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Pike install linuxbridge-agent.service failed on Compute

I inherited a somewhat flaky openstack installation at work so I’m trying to go through the install to understand how these things work. I pulled 3 boxes out of inventory and am working my way through it.

Each box is has enp0s25 and enp0s20u1. enp0s25 is on the management network, enp0s20u1 is plugged into a hub which is connected to the enp0s25 interface on the other boxes. I’m not sure if this is correct or not. Please correct me if this sounds wrong.

I installed Centos on all the machines and have been proceeding through the installation everything went fine (well, I worked through all the errors) until I hit this one. I’ve gone through the results on this site and found similar issues but not found the resolution for this.

I’ve gone through the config files in the instructions (https://docs.openstack.org/neutron/pike/install/install-rdo.html) multiple times, but I must be missing something. I’ve followed the instructions to the letter (I think) with the exception of the ip address on the mgmt. network (to make my routing easier).

I followed the steps for self service networks (don’t fully understand the difference though), because that's what the work configuration is.

On Controller: enp0s25 has IP 192.168.1.186, enp0s25 has no IP neutron agent-list shows that these are all running on controller. • DHCP agent • Linux bridge agent • Metadata agent • L3 agent

On Compute1: enp0s25 has IP 192.168.1.187, enp0s25 has no IP $ neutron agent-list Connection to neutron failed: Failed to connect Neutron server. (I had to open a firewall port 35357 on controller to get it this far) Should this work?

So there’s that, but linuxbridge agent can’t start:

$ systemctl status neutron-linuxbridge-agent.service neutron-linuxbridge-agent.service - OpenStack Neutron Linux Bridge Agent Loaded: loaded (/usr/lib/systemd/system/neutron-linuxbridge-agent.service; enabled; vendor preset: disabled) Active: failed (Result: start-limit) since Mon 2018-02-12 21:16:52 EST; 38min ago Process: 4514 ExecStart=/usr/bin/neutron-linuxbridge-agent --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/linuxbridge_agent.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-linuxbridge-agent --log-file /var/log/neutron/linuxbridge-agent.log (code=exited, status=1/FAILURE) Process: 4508 ExecStartPre=/usr/bin/neutron-enable-bridge-firewall.sh (code=exited, status=0/SUCCESS) Main PID: 4514 (code=exited, status=1/FAILURE)

Feb 12 21:16:52 compute1 systemd[1]: Unit neutron-linuxbridge-agent.service entered failed state. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service failed. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service holdoff time over, scheduling restart. Feb 12 21:16:52 compute1 systemd[1]: start request repeated too quickly for neutron-linuxbridge-agent.service Feb 12 21:16:52 compute1 systemd[1]: Failed to start OpenStack Neutron Linux Bridge Agent. Feb 12 21:16:52 compute1 systemd[1]: Unit neutron-linuxbridge-agent.service entered failed state. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service failed.

And in the linuxbridge-agent.log:

2018-02-12 21:16:52.571 4514 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip 192.168.1.186 on the host interface to be used for tunneling and restart the agent.

But the local_ip is configured. It’s pointing to the mgmt. interface on the controller which is what the instructions (and several other posts) say to do. I'm not sure what port (if any) may be blocked by a firewall.

I can ping all of the mgmt. interfaces from all of the boxes. I did install the openstack selinux packages. Everything has worked up to this point.

I’m not sure how this is supposed to work. Is this using the management interfaces to make this connection? I’m baffled here and slightly over my head. Is this a firewall issue? If so, how do I correct it?

Any help is appreciated