Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ssh into vm is slow but only for some vm's on openstack

I used kolla 5.0.0 to deploy openstack on one control node and one compute node both running Centos 7. Everything seems to work well but the ssh login just takes too long. It takes almost a whole minute to log me into a vm on openstack. People have suggested it could be related to DNS so I have tried things like changing the option UseDNS to equal "no" in /etc/ssh/sshd_config ON the vm's. I also tried setting GSSAPIAuthentication to "no" in /etc/ssh/sshd_config on the vm's and restarted the sshd but these suggestions did not help anything.

The thing that is confusing me is that one of my instance I created does not give me trouble when I ssh into it but all the rest do. All my current instance were launched from snapshots of other vm's on another openstack environment. All the snapshots have Centos 7.

So why is it that most of my vm's take almost a minute to ssh into but one of them works just fine and has no delay when I ssh into it? Could this still be related to DNS?

Any suggestions on why this could be happening?