Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gnocchi triggering keystone error

Hello,

On my attempts to run the stack.sh script trying to install the Gnocchi plugin integrated with Ceilometer, I'm getting the following output as the result:

+./stack.sh:main:1070                      create_keystone_accounts
+lib/keysto
ne:create_keystone_accounts:383  local admin_project
++lib/keystone:create_keystone_accounts:384  openstack project show admin -f value -c id
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Could not determine a suitable URL for the plugin
+lib/keystone:create_keystone_accounts:384  admin_project=
+lib/keystone:create_keystone_accounts:1   exit_trap
+./stack.sh:exit_trap:494                  local r=1
++./stack.sh:exit_trap:495                  jobs -p
+./stack.sh:exit_trap:495                  jobs=
+./stack.sh:exit_trap:498                  [[ -n '' ]]
+./stack.sh:exit_trap:504                  kill_spinner
+./stack.sh:kill_spinner:390               '[' '!' -z '' ']'
+./stack.sh:exit_trap:506                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:507                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:508                  generate-subunit 1513110720 4151 fail
+./stack.sh:exit_trap:509                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:512                  /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2017-12-12-214111.txt for details
+./stack.sh:exit_trap:518                  exit 1

This is the content of my local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=stack
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD

enable_plugin heat https://git.openstack.org/openstack/heat stable/ocata
enable_plugin tacker https://git.openstack.org/openstack/tacker stable/ocata
CEILOMETER_EVENT_ALARM=True
CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/ocata
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/ocata

The error only shows up when the line "CEILOMETER_BACKEND=gnocchi" is added to the local.conf file. The installation is successful otherwise.

After some research, I've seen cases where similar problems were solved by adding the machine's ip to the no_proxy variable or by commenting a few lines of the stack.sh script, but none of these solutions worked for me. Does anyone know what can be done to solve this problem?