Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Ocata > Pike: Service is older on server list

Hi i am running Openstack on Ubuntu 16.04 with cloud-archive ppa enabled. After upgrading from ocata to pike i get the following error when try an "openstack server list"

This service is older (v15) than the minimum (v22) version of the rest of the deployment. Unable to continue. (HTTP 400) (Request-ID: req-b74ffd6b-0fad-40cc-8fe6-160760518869)

Any suggestions how I can track this error?


root@controller:~# dpkg-query -l |grep nova |cut -b 1-65
ii  nova-api                           2:16.0.1-0ubuntu1~cloud0  
ii  nova-common                        2:16.0.1-0ubuntu1~cloud0  
ii  nova-conductor                     2:16.0.1-0ubuntu1~cloud0  
ii  nova-consoleauth                   2:16.0.1-0ubuntu1~cloud0  
ii  nova-novncproxy                    2:16.0.1-0ubuntu1~cloud0  
ii  nova-placement-api                 2:16.0.1-0ubuntu1~cloud0  
ii  nova-scheduler                     2:16.0.1-0ubuntu1~cloud0  
ii  python-nova                        2:16.0.1-0ubuntu1~cloud0  
ii  python-novaclient                  2:9.1.0-0ubuntu1~cloud0