Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Issue with spawing vm on public network

Hi, We have installed openstack -pike via kolla-ansible.It is a 2 node node setup where node1 acts as controller,network and compute and node2 just as compute.

While spawing vm in a public network we saw an issue that all vm were being scheduled at node1 and when we tried to spawn vm at node 2 we saw "No valid host found issue".In logs it showed "port binding failed"

there was no issue however in spawning vm in node2 at private network

After adding br-ex in compute node ie node2 the vm in public network started spawning at compute node as well. we came across a bug which removed br-ex from compute node in ocata release. bug : https://review.openstack.org/#/c/460645/ However in doing so the openstack installation becomes incapable of launching vm in public network . Is there something i am missing.can the vm be spawned at public netwok without br-ex in compute node.

Please help.

Issue with spawing vm on public network

Hi, We have installed openstack -pike via kolla-ansible.It is a 2 node node setup where node1 acts as controller,network and compute and node2 just as compute.

While spawing vm in a public network we saw an issue that all vm were being scheduled at node1 and when we tried to spawn vm at node 2 we saw "No valid host found issue".In logs it showed "port binding failed"

there was no issue however in spawning vm in node2 at private network

After adding br-ex in compute node ie node2 the vm in public network started spawning at compute node as well. we came across a bug which removed br-ex from compute node in ocata release. release.

bug : https://review.openstack.org/#/c/460645/ https://review.openstack.org/#/c/460645/

However in doing so the openstack installation becomes incapable of launching vm in public network . Is there something i am missing.can the vm be spawned at public netwok without br-ex in compute node.

Please help.