Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Dashboard overview stuck in "loading"

I have a problem that started after the upgrade to Pike. When I click on the dashboard's "Overview", it gets stuck in loading, and the nova-api logs show this line 4 times per second in a loop, over and over:

2017-10-06 09:42:18.170 7383 INFO nova.osapi_compute.wsgi.server [req-9cf0dd87-bfec-40eb-ad50-bb0aa646b822 2bcbe1b9694d45d0b2114d3d18408be8 eb43f6dfa2764e2eb8bb8d4d95e1b1e0 - default default] 10.157.254.2 "GET /v2.1/eb43f6dfa2764e2eb8bb8d4d95e1b1e0/os-simple-tenant-usage?start=2017-10-05T00:00:00&end=2017-10-06T23:59:59&marker=4a1b34f5-9fdd-4204-a527-e873c558b679&detailed=1 HTTP/1.1" status: 200 len: 4606 time: 0.2725942

After restarting openstack-nova-api, dashboard shows the message:

Error: Unable to retrieve usage information.
Error: Unable to retrieve limit information.

These lines from the CLI work ok though:

openstack usage show --project admin --start 2017-10-05 --end 2017-10-06
openstack usage list --start 2017-10-05 --end 2017-10-06

(Not sure how to specify an instance in those commands, to emulate the "marker" part of the URL in the loop)

Any help on troubleshooting this issue will be greatly appreciated!

[Running Pike on CentOS 7, installed manually, keystone, horizon, nova, neutron, cinder, swift, glance]

Dashboard overview stuck in "loading"

I have a problem that started after the upgrade to Pike. When I click on the dashboard's "Overview", it gets stuck in loading, and the nova-api logs show this line 4 times per second in a loop, over and over:

2017-10-06 09:42:18.170 7383 INFO nova.osapi_compute.wsgi.server [req-9cf0dd87-bfec-40eb-ad50-bb0aa646b822 2bcbe1b9694d45d0b2114d3d18408be8 eb43f6dfa2764e2eb8bb8d4d95e1b1e0 - default default] 10.157.254.2 "GET /v2.1/eb43f6dfa2764e2eb8bb8d4d95e1b1e0/os-simple-tenant-usage?start=2017-10-05T00:00:00&end=2017-10-06T23:59:59&marker=4a1b34f5-9fdd-4204-a527-e873c558b679&detailed=1 HTTP/1.1" status: 200 len: 4606 time: 0.2725942

After restarting openstack-nova-api, dashboard shows the message:

Error: Unable to retrieve usage information.
Error: Unable to retrieve limit information.

These lines from the CLI work ok though:

openstack usage show --project admin --start 2017-10-05 --end 2017-10-06
openstack usage list --start 2017-10-05 --end 2017-10-06

(Not sure how to specify an instance in those commands, to emulate the "marker" part of the URL in the loop)

Any help on troubleshooting this issue will be greatly appreciated!

[Running Pike on CentOS 7, installed manually, keystone, horizon, nova, neutron, cinder, swift, glance]glance, ceph]