Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Multinode Lab Devstack: No sql_connection parameter is established

Hi, I installed my environment using Devstack. I get this error when I'm trying to launch an instance:

File "/opt/stack/nova/nova/conductor/", line 553, in build_instances context, spec_obj, instance_uuids) File "/opt/stack/nova/nova/conductor/", line 624, in _schedule_instances scheduler_utils.setup_instance_group(context, request_spec) File "/opt/stack/nova/nova/scheduler/", line 564, in setup_instance_group group_info = _get_group_details(context, instance_uuid, group_hosts) File "/opt/stack/nova/nova/scheduler/", line 521, in _get_group_details instance_uuid) File "/usr/local/lib/python2.7/dist-packages/oslo_versionedobjects/", line 184, in wrapper result = fn(cls, context, *args, **kwargs) File "/opt/stack/nova/nova/objects/", line 331, in get_by_instance_uuid db_group = cls._get_from_db_by_instance(context, instance_uuid) File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 983, in wrapper with self._transaction_scope(context): File "/usr/lib/python2.7/", line 17, in __enter__ return File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 1033, in _transaction_scope context=context) as resource: File "/usr/lib/python2.7/", line 17, in __enter__ return File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 638, in _session bind=self.connection, mode=self.mode) File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 403, in _create_session self._start() File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 489, in _start engine_args, maker_args) File "/usr/local/lib/python2.7/dist-packages/oslo_db/sqlalchemy/", line 511, in _setup_for_connection "No sql_connection parameter is established")

Is there a way to set manually the sql_connection parameter?

Do I have to change this on my nova.conf file?

connection = mysql+pymysql://root:nenci@

connection = mysql+pymysql://root:nenci@