Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

multiple tenant network problem

Hi, I have two separated physical networks and I want use them to provide clan tenants networks on Openstack Juno. These are the physical networks: physnet1 and heartbeat corresponding to two NIC eth0 and eth1. My configuration is:

[ml2_type_vlan]
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

bridge_mappings = physnet1:br-eth0, heartbeat:br-eth1

I mapped the bridges through:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0

ovs-vsctl add-br br-eth1
ovs-vsctl add-port br-eth1 eth1

As admin I created the two tenant networks:

Network Type: vlan
Physical Network: physnet1
Segmentation ID: 976

and

Network Type: vlan
Physical Network: heartbeat
Segmentation ID: 786

When I create a VM attached to heartbeat network the ifconfig command shows the tagged interface eth0.786. This behavior is unexpected because I should have eth1.786. What's wrong?

multiple tenant network problem

Hi, I have two separated physical networks and I want use them to provide clan tenants networks on Openstack Juno. These are the physical networks: physnet1 and heartbeat corresponding to two NIC eth0 and eth1. My configuration is:

[ml2_type_vlan]
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

bridge_mappings = physnet1:br-eth0, heartbeat:br-eth1

I mapped the bridges through:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0

ovs-vsctl add-br br-eth1
ovs-vsctl add-port br-eth1 eth1

As admin I created the two tenant networks:

Network Type: vlan
Physical Network: physnet1
Segmentation ID: 976

and

Network Type: vlan
Physical Network: heartbeat
Segmentation ID: 786

When I create a VM attached to heartbeat network the ifconfig command shows the tagged interface eth0.786. This behavior is unexpected because I should have eth1.786. What's wrong?

multiple tenant network problemon multiple physical networks

Hi, I have two separated physical networks and I want use them to provide clan vlan tenants networks on Openstack Juno. These are the physical networks: physnet1 and heartbeat corresponding to two NIC eth0 and eth1. My configuration is:

[ml2_type_vlan]
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

bridge_mappings = physnet1:br-eth0, heartbeat:br-eth1

I mapped the bridges through:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0

ovs-vsctl add-br br-eth1
ovs-vsctl add-port br-eth1 eth1

As admin I created the two tenant networks:

Network Type: vlan
Physical Network: physnet1
Segmentation ID: 976

and

Network Type: vlan
Physical Network: heartbeat
Segmentation ID: 786

When I create a VM attached to heartbeat network the ifconfig command shows the tagged interface eth0.786. This behavior is unexpected because I should have eth1.786. What's wrong?