Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

node linuxbridge agent is not listed in network agent list

Hi,

I have trouble with then linuxbridge agent on my compute node. I've installed Openstack ocata following the official guide and used networking option 2.

running openstack network agent list lists all components of the controller, but not the compute nod

e.
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+
| ID                                   | Agent Type         | Host       | Availability Zone | Alive | State | Binary                    |
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+
| 5950d35a-a0f9-4f8f-9994-24a56da0192f | L3 agent           | controller | nova              | True  | UP    | neutron-l3-agent          |
| c05d98e9-c643-447c-88b0-919c50bc7e10 | Metadata agent     | controller | None              | True  | UP    | neutron-metadata-agent    |
| c6241107-5c36-46c1-895c-54217131304a | DHCP agent         | controller | nova              | True  | UP    | neutron-dhcp-agent        |
| eab927fc-6c71-4d9f-bbe2-c736cb6e73bf | Linux bridge agent | controller | None              | True  | UP    | neutron-linuxbridge-agent |
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+

The /var/log/neutron/neutron-linuxbridge-agent.log looks like that.

2017-08-28 14:46:33.536 7979 INFO neutron.common.config [-] Logging enabled!
2017-08-28 14:46:33.537 7979 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 10.0.2
2017-08-28 14:46:33.537 7979 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {}
2017-08-28 14:46:33.537 7979 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2017-08-28 14:46:33.538 7979 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip None on the host interface to be used for tunneling and restart the agent.
2017-08-28 14:46:37.484 8031 INFO neutron.common.config [-] Logging enabled!
2017-08-28 14:46:37.485 8031 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 10.0.2
2017-08-28 14:46:37.485 8031 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {}
2017-08-28 14:46:37.485 8031 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2017-08-28 14:46:37.486 8031 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip None on the host interface to be used for tunneling and restart the agent.

My linuxbridge_agent.ini file looks like that:

[vxlan]

#
# From neutron.ml2.linuxbridge.agent
#

# Enable VXLAN on the agent. Can be enabled when agent is managed by ml2 plugin
# using linuxbridge mechanism driver (boolean value)
enable_vxlan = true

# TTL for vxlan interface protocol packets. (integer value)
#ttl = <None>

# TOS for vxlan interface protocol packets. (integer value)
#tos = <None>

# Multicast group(s) for vxlan interface. A range of group addresses may be
# specified by using CIDR notation. Specifying a range allows different VNIs to
# use different group addresses, reducing or eliminating spurious broadcast
# traffic to the tunnel endpoints. To reserve a unique group for each possible
# (24-bit) VNI, use a /8 such as 239.0.0.0/8. This setting must be the same on
# all the agents. (string value)
#vxlan_group = 224.0.0.1

# IP address of local overlay (tunnel) network endpoint. Use either an IPv4 or
# IPv6 address that resides on one of the host network interfaces. The IP
# version of this value must match the value of the 'overlay_ip_version' option
# in the ML2 plug-in configuration file on the neutron server node(s). (IP
# address value)
local_ip = 192.168.0.82

# Extension to use alongside ml2 plugin's l2population mechanism driver. It
# enables the plugin to populate VXLAN forwarding table. (boolean value)
l2_population = true

I don't understand why the error states that there is no IP

I hope that someone can help me.

node linuxbridge agent is not listed in network agent list

Hi,

I have trouble with then linuxbridge agent on my compute node. I've installed Openstack ocata following the official guide and used networking option 2.

running openstack network agent list lists all components of the controller, but not the compute nod

e.
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+
| ID                                   | Agent Type         | Host       | Availability Zone | Alive | State | Binary                    |
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+
| 5950d35a-a0f9-4f8f-9994-24a56da0192f | L3 agent           | controller | nova              | True  | UP    | neutron-l3-agent          |
| c05d98e9-c643-447c-88b0-919c50bc7e10 | Metadata agent     | controller | None              | True  | UP    | neutron-metadata-agent    |
| c6241107-5c36-46c1-895c-54217131304a | DHCP agent         | controller | nova              | True  | UP    | neutron-dhcp-agent        |
| eab927fc-6c71-4d9f-bbe2-c736cb6e73bf | Linux bridge agent | controller | None              | True  | UP    | neutron-linuxbridge-agent |
+--------------------------------------+--------------------+------------+-------------------+-------+-------+---------------------------+

The /var/log/neutron/neutron-linuxbridge-agent.log looks like that.

2017-08-28 14:46:33.536 7979 INFO neutron.common.config [-] Logging enabled!
2017-08-28 14:46:33.537 7979 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 10.0.2
2017-08-28 14:46:33.537 7979 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {}
2017-08-28 14:46:33.537 7979 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2017-08-28 14:46:33.538 7979 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip None on the host interface to be used for tunneling and restart the agent.
2017-08-28 14:46:37.484 8031 INFO neutron.common.config [-] Logging enabled!
2017-08-28 14:46:37.485 8031 INFO neutron.common.config [-] /usr/bin/neutron-linuxbridge-agent version 10.0.2
2017-08-28 14:46:37.485 8031 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Interface mappings: {}
2017-08-28 14:46:37.485 8031 INFO neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Bridge mappings: {}
2017-08-28 14:46:37.486 8031 ERROR neutron.plugins.ml2.drivers.linuxbridge.agent.linuxbridge_neutron_agent [-] Tunneling cannot be enabled without the local_ip bound to an interface on the host. Please configure local_ip None on the host interface to be used for tunneling and restart the agent.

My linuxbridge_agent.ini file looks like that:

[vxlan]

#
# From neutron.ml2.linuxbridge.agent
#

# Enable VXLAN on the agent. Can be enabled when agent is managed by ml2 plugin
# using linuxbridge mechanism driver (boolean value)
enable_vxlan = true

# TTL for vxlan interface protocol packets. (integer value)
#ttl = <None>

# TOS for vxlan interface protocol packets. (integer value)
#tos = <None>

# Multicast group(s) for vxlan interface. A range of group addresses may be
# specified by using CIDR notation. Specifying a range allows different VNIs to
# use different group addresses, reducing or eliminating spurious broadcast
# traffic to the tunnel endpoints. To reserve a unique group for each possible
# (24-bit) VNI, use a /8 such as 239.0.0.0/8. This setting must be the same on
# all the agents. (string value)
#vxlan_group = 224.0.0.1

# IP address of local overlay (tunnel) network endpoint. Use either an IPv4 or
# IPv6 address that resides on one of the host network interfaces. The IP
# version of this value must match the value of the 'overlay_ip_version' option
# in the ML2 plug-in configuration file on the neutron server node(s). (IP
# address value)
local_ip = 192.168.0.82

# Extension to use alongside ml2 plugin's l2population mechanism driver. It
# enables the plugin to populate VXLAN forwarding table. (boolean value)
l2_population = true

I don't understand why the error states that there is no IP

I hope that someone can help me.