Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

horizon does not work after neutron endpoint creation in keystone

I was trying to install openstack in ubuntu 12.04(LTS).

As installtion procedure I was following the openstack havana installtion guide at docs.openstack.org. Everything was fine until now. But recently I am facing a problem and cant find solution.

I am facing problem with horizon right after creating the keystone end point for the neutron service.

My dashboard stops working and shows "Internal Server Error" after providing the command:

# keystone endpoint-create \ --service-id the_service_id_above \ --publicurl http://controller:9696 \ --adminurl http://controller:9696 \ --internalurl http://controller:9696

The error is with the Apache2 and when i goto apache2 error logs it show:

"OfflineGenerationError: You have offline compression enabled but key "3ddd89d27fa2e162d4efd30c103a072b" is missing from offline manifest. You may need to run "python manage.py compress"

The problem is not solved even if I run

python manage.py compress

Please help me regarding this issue.