Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file: INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service] MountFlags=shared EnvironmentFile=/etc/sysconfig/docker ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands: sudo systemctl daemon-reload sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l [sudo] password for cloudmaster: ● docker.service - Docker Application Container Engine Loaded: error (Reason: Invalid argument) Drop-In: /etc/systemd/system/docker.service.d └─kolla.conf Active: inactive (dead) Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

modify the /etc/sysconfig/docker

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

/etc/sysconfig/docker

Adding to the file: file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile environmentFile variable and add $DOCKER_OPTS $DOCKER_OPTS to the end of ExecStart ExecStart in [Service] [Service] section:

sudo nano /etc/systemd/system/docker.service

/etc/systemd/system/docker.service [Service] MountFlags=shared EnvironmentFile=/etc/sysconfig/docker ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

$INSECURE_REGISTRY Restart Docker by executing the following commands: sudo systemctl daemon-reload sudo systemctl restart docker

docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

https://docs.docker.com Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY
 

Restart Docker by executing the following commands: commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

--- UPDATE---

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

[bobtheuser@kolla ~]$ sudo systemctl status docker.service
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: failed (Result: start-limit) since Mon 2017-08-21 08:06:16 EDT; 52s ago
     Docs: https://docs.docker.com
  Process: 2661 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
 Main PID: 2661 (code=exited, status=1/FAILURE)

Aug 21 08:06:16 kolla.lab systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:06:16 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

--- UPDATE---

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

[bobtheuser@kolla ~]$ sudo systemctl status docker.service
● docker.service - Docker Application Container Engine
   Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: failed (Result: start-limit) since Mon 2017-08-21 08:06:16 EDT; 52s ago
     Docs: https://docs.docker.com
  Process: 2661 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
 Main PID: 2661 (code=exited, status=1/FAILURE)

Aug 21 08:06:16 kolla.lab systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE
Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:06:16 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

--- UPDATE---

I forgot to mention that I had performed this setting suggestion in earlier attempt, since it was the main course of action suggested online. Sadly still results in a failed docker start. But to give information for trouble shooting, here is what happens under that change.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service ● docker.service - Docker Application Container Engine Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled) Drop-In: /etc/systemd/system/docker.service.d └─kolla.conf Active: failed (Result: start-limit) since Mon 2017-08-21 08:06:16 EDT; 52s ago Docs: https://docs.docker.com Process: 2661 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE) Main PID: 2661 (code=exited, status=1/FAILURE)

Aug 21 08:06:16 kolla.lab systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine. Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state. Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed. Aug 21 08:06:16 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart. Aug 21 08:06:16 kolla.lab systemd[1]: start request repeated too quickly for docker.service Aug 21 08:06:16 kolla.lab systemd[1]: Failed to start Docker Application Container Engine. Aug 21 08:06:16 kolla.lab systemd[1]: Unit docker.service entered failed state. Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

--- UPDATE---

I forgot to mention that I had performed this setting suggestion in earlier attempt, since it was the main course of action suggested online. Sadly still results in a failed docker start. But to give information for trouble shooting, here is what happens under that change.

Update 1: 

[bobtheuser@kolla ~]$ cloudmaster]# sudo systemctl status docker.service -l ● docker.service - Docker Application Container Engine Engine Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled) disabled) Drop-In: /etc/systemd/system/docker.service.d └─kolla.conf /etc/systemd/system/docker.service.d └─kolla.conf Active: failed (Result: start-limit) since Mon 2017-08-21 08:06:16 08:42:48 EDT; 52s ago 2s ago Docs: https://docs.docker.com https://docs.docker.com Process: 2661 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE) status=1/FAILURE) Main PID: 2661 2536 (code=exited, status=1/FAILURE) Aug 21 08:06:16 kolla.lab systemd[1]: docker.service: main process exited, code=exited, status=1/FAILURE Aug 21 08:06:16 status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine. Aug 21 08:06:16 Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state. Aug 21 08:06:16 kolla.lab systemd[1]: docker.service failed. Aug 21 08:06:16 state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart. Aug 21 08:06:16 restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service Aug 21 08:06:16 docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine. Aug 21 08:06:16 Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state. Aug 21 08:06:16 state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
 ● docker.service - Docker Application Container Engine
 Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
 Drop-In: /etc/systemd/system/docker.service.d
 └─kolla.conf
 Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
 Docs: https://docs.docker.com
 Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
 Main PID: 2536 (code=exited, status=1/FAILURE)

status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 2:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: error (Reason: Invalid argument)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:46:35 EDT; 1min 13s ago
Docs: https://docs.docker.com
Main PID: 2612 (code=exited, status=1/FAILURE)

Aug 21 08:46:34 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:34 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:34 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:46:35 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:46:35 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:35 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:47:42 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only 
allowed for Type=oneshot services. Refusing.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 2:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: error (Reason: Invalid argument)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:46:35 EDT; 1min 13s ago
Docs: https://docs.docker.com
Main PID: 2612 (code=exited, status=1/FAILURE)

Aug 21 08:46:34 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:34 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:34 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:46:35 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:46:35 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:35 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:47:42 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only 
allowed for Type=oneshot services. Refusing.

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 2:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: error (Reason: Invalid argument)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:46:35 EDT; 1min 13s ago
Docs: https://docs.docker.com
Main PID: 2612 (code=exited, status=1/FAILURE)

Aug 21 08:46:34 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:34 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:34 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:46:35 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:46:35 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:46:35 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:46:35 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:47:42 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only 
allowed for Type=oneshot services. Refusing.
2:
/etc/systemd/system/docker.service.d/kolla.conf file contents:

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=
ExecStart=/usr/bin/dockerd $INSECURE_REGISTRY

/etc/sysconfig/docker file contents:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 2: 2

/etc/systemd/system/docker.service.d/kolla.conf file contents:

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=
ExecStart=/usr/bin/dockerd $INSECURE_REGISTRY

/etc/sysconfig/docker file contents:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 22:

/etc/systemd/system/docker.service.d/kolla.conf file contents:

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=
ExecStart=/usr/bin/dockerd $INSECURE_REGISTRY

/etc/sysconfig/docker file contents:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Thanks, -EchoGhost

How to setup docker insecure registry for kolla?

I have been working through the kolla ansible installation for openstack. Ocata Guide I am using here . Currently using 3x centos 7 virtual machines in order to test a multi node deployment method. The problem I am running into is when deploying the insecure registry.

The following are the steps I am taking.

sudo /usr/share/kolla/tools/start-registry

Modify the /etc/sysconfig/docker file to contain the following where 192.168.1.100 is the IP address of the machine where the registry is currently running:

sudo nano /etc/sysconfig/docker

Adding to the file:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Next, modify /etc/systemd/system/docker.service.d/kolla.conf, add environmentFile variable and add $DOCKER_OPTS to the end of ExecStart in [Service] section:

sudo nano /etc/systemd/system/docker.service

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY

Restart Docker by executing the following commands:

sudo systemctl daemon-reload
sudo systemctl restart docker

Upon going through these steps, end up with the following result:

[bobtheuser@kolla ~]$ sudo systemctl restart docker
Failed to restart docker.service: Unit is not loaded properly: Invalid argument.

looking into the error more, I have the following information.

[bobtheuser@kolla ~]$ sudo systemctl status docker.service -l
[sudo] password for cloudmaster:
● docker.service - Docker Application Container Engine
   Loaded: error (Reason: Invalid argument)
  Drop-In: /etc/systemd/system/docker.service.d
           └─kolla.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Aug 18 09:16:17 kolla.lab systemd[1]: docker.service has more than one ExecStart= setting, which is only allowed for Type=oneshot services. Refusing.

I have looked around online to see if anyone else has encountered this issue, but with no results. It seems to be an error with the ExecStart. Is there something that I am missing or a different procedure that needs to be followed?

Update 1:

[bobtheuser@kolla cloudmaster]# sudo systemctl status docker.service -l
● docker.service - Docker Application Container Engine
Loaded: loaded (/usr/lib/systemd/system/docker.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/docker.service.d
└─kolla.conf
Active: failed (Result: start-limit) since Mon 2017-08-21 08:42:48 EDT; 2s ago
Docs: https://docs.docker.com
Process: 2536 ExecStart=/usr/bin/docker daemon $INSECURE_REGISTRY (code=exited, status=1/FAILURE)
Main PID: 2536 (code=exited, status=1/FAILURE)

Aug 21 08:42:47 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:47 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:47 kolla.lab systemd[1]: docker.service failed.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service holdoff time over, scheduling restart.
Aug 21 08:42:48 kolla.lab systemd[1]: start request repeated too quickly for docker.service
Aug 21 08:42:48 kolla.lab systemd[1]: Failed to start Docker Application Container Engine.
Aug 21 08:42:48 kolla.lab systemd[1]: Unit docker.service entered failed state.
Aug 21 08:42:48 kolla.lab systemd[1]: docker.service failed.

Update 2:2: Correctly working file configurations.

/etc/systemd/system/docker.service.d/kolla.conf file contents:

[Service]
MountFlags=shared
EnvironmentFile=/etc/sysconfig/docker
ExecStart=
ExecStart=/usr/bin/dockerd $INSECURE_REGISTRY

/etc/sysconfig/docker file contents:

INSECURE_REGISTRY="--insecure-registry 192.168.1.100:5000"

Thanks, -EchoGhost