Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

instance is not able to ping the internet but able to ping the openstack server

Hi,

I have installed the packstact ocata. I have manually created the public network which is in the same network my dashboard runs.

Dashboard URL: http://10.211.2.21/dashboard/auth/login/?next=/dashboard/

I have also created the private network and also a router. After launching the cirros instance and assigning the floating IP, it has taken the IP as 10.211.2.32.

From the Openstack server (10.211.2.21) I am able to ping the floating IP 10.211.2.32 and also login via SSH.

[root@openstack ~]# ssh cirros@10.211.2.32
cirros@10.211.2.32's password:
$ hostname
cirros
$

My Openstack server (10.211.2.21) is able to ping the internet as below.

[root@openstack ~]# ping google.com
PING google.com (216.58.220.46) 56(84) bytes of data.
64 bytes from maa03s18-in-f14.1e100.net (216.58.220.46): icmp_seq=1 ttl=52 time=31.8 ms
64 bytes from maa03s18-in-f14.1e100.net (216.58.220.46): icmp_seq=2 ttl=52 time=32.4 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 31.888/32.150/32.413/0.317 ms
[root@openstack ~]# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=27.9 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=28.0 ms
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 27.952/27.979/28.006/0.027 ms
[root@openstack ~]# cat /etc/resolv.conf

nameserver 172.17.33.64
[root@openstack ~]#

But when I try to do it from the instance (10.211.2.32) I am not able to ping the internet.

$ cat /etc/resolv.conf
nameserver 10.10.10.2
$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
14 packets transmitted, 0 packets received, 100% packet loss
$ ping 10.211.2.254
PING 10.211.2.254 (10.211.2.254): 56 data bytes
^C
--- 10.211.2.254 ping statistics ---
41 packets transmitted, 0 packets received, 100% packet loss
$
$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr FA:16:3E:7F:EB:01
          inet addr:10.10.10.10  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe7f:eb01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1450  Metric:1
          RX packets:832 errors:0 dropped:0 overruns:0 frame:0
          TX packets:681 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:78362 (76.5 KiB)  TX bytes:68828 (67.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:46 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4192 (4.0 KiB)  TX bytes:4192 (4.0 KiB)

$ traceroute 10.211.2.254
traceroute to 10.211.2.254 (10.211.2.254), 30 hops max, 46 byte packets
 1  host-10-10-10-1.openstacklocal (10.10.10.1)  0.351 ms  0.085 ms  0.076 ms
 2  *  *  10.211.2.32 (10.211.2.32)  3007.548 ms !H
 3  10.211.2.32 (10.211.2.32)  3006.438 ms !H  3005.925 ms !H  3007.605 ms !H
$

Any help will be highly appreciated.

Regards, Gaurav

instance is not able to ping the internet but able to ping the openstack server

Hi,

I have installed the packstact ocata. I have manually created the public network which is in the same network my dashboard runs.

Dashboard URL: http://10.211.2.21/dashboard/auth/login/?next=/dashboard/

I have also created the private network and also a router. After launching the cirros instance and assigning the floating IP, it has taken the IP as 10.211.2.32.

From the Openstack server (10.211.2.21) I am able to ping the floating IP 10.211.2.32 and also login via SSH.

[root@openstack ~]# ssh cirros@10.211.2.32
cirros@10.211.2.32's password:
$ hostname
cirros
$

My Openstack server (10.211.2.21) is able to ping the internet as below.

[root@openstack ~]# ping google.com
PING google.com (216.58.220.46) 56(84) bytes of data.
64 bytes from maa03s18-in-f14.1e100.net (216.58.220.46): icmp_seq=1 ttl=52 time=31.8 ms
64 bytes from maa03s18-in-f14.1e100.net (216.58.220.46): icmp_seq=2 ttl=52 time=32.4 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 31.888/32.150/32.413/0.317 ms
[root@openstack ~]# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=27.9 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=28.0 ms
^C
--- 8.8.8.8 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 27.952/27.979/28.006/0.027 ms
[root@openstack ~]# cat /etc/resolv.conf

nameserver 172.17.33.64
[root@openstack ~]#

But when I try to do it from the instance (10.211.2.32) I am not able to ping the internet.

$ cat /etc/resolv.conf
nameserver 10.10.10.2
$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
^C
--- 8.8.8.8 ping statistics ---
14 packets transmitted, 0 packets received, 100% packet loss
$ ping 10.211.2.254
PING 10.211.2.254 (10.211.2.254): 56 data bytes
^C
--- 10.211.2.254 ping statistics ---
41 packets transmitted, 0 packets received, 100% packet loss
$
$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr FA:16:3E:7F:EB:01
          inet addr:10.10.10.10  Bcast:10.10.10.255  Mask:255.255.255.0
          inet6 addr: fe80::f816:3eff:fe7f:eb01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1450  Metric:1
          RX packets:832 errors:0 dropped:0 overruns:0 frame:0
          TX packets:681 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:78362 (76.5 KiB)  TX bytes:68828 (67.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:46 errors:0 dropped:0 overruns:0 frame:0
          TX packets:46 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4192 (4.0 KiB)  TX bytes:4192 (4.0 KiB)

$ traceroute 10.211.2.254
traceroute to 10.211.2.254 (10.211.2.254), 30 hops max, 46 byte packets
 1  host-10-10-10-1.openstacklocal (10.10.10.1)  0.351 ms  0.085 ms  0.076 ms
 2  *  *  10.211.2.32 (10.211.2.32)  3007.548 ms !H
 3  10.211.2.32 (10.211.2.32)  3006.438 ms !H  3005.925 ms !H  3007.605 ms !H
$

Below is the Security Group.

[root@openstack ~(keystone_admin)]# openstack security group rule list 9a85d446-2f13-434b-9aec-e6992bdeeb1d
+--------------------------------------+-------------+-----------+------------+-----------------------+
| ID                                   | IP Protocol | IP Range  | Port Range | Remote Security Group |
+--------------------------------------+-------------+-----------+------------+-----------------------+
| 13efa65e-86a8-4b42-8636-fc2bde682b2b | tcp         | 0.0.0.0/0 | 22:22      | None                  |
| 23bfa06b-4df0-4376-aba9-7d3746f3c557 | tcp         | 0.0.0.0/0 | 1:65535    | None                  |
| 3bc9cb7c-acaa-47b2-aca8-d840ee2b8030 | udp         | 0.0.0.0/0 | 1:65535    | None                  |
| 43e04ba7-c139-45b4-a2c6-ed12dfff0330 | udp         | 0.0.0.0/0 | 1:65535    | None                  |
| 967b48df-fc48-4430-a76d-20eaf660231f | tcp         | 0.0.0.0/0 | 1:65535    | None                  |
| d1735807-e546-42c4-8825-4a6ec777d28e | icmp        | 0.0.0.0/0 |            | None                  |
| f324d486-a782-4c48-8071-b56453e4117d | icmp        | 0.0.0.0/0 |            | None                  |
+--------------------------------------+-------------+-----------+------------+-----------------------+
[root@openstack ~(keystone_admin)]#

Any help will be highly appreciated.

Regards, Gaurav