Revision history [back]

click to hide/show revision 1
initial version

Problem Creating Volume Backups

I am trying to create a backup of a root volume and whose instance is in running state using :

 cinder backup-create --name BackupTest de3e9f5b-a628-4fa4-812c-b35ee1a9e29e --force

The output is :

+-----------+--------------------------------------+
| Property  | Value                                |
+-----------+--------------------------------------+
| id        | d9c49ba8-6614-42b6-b591-07ac378260a1 |
| name      | BackupTest                           |
| volume_id | de3e9f5b-a628-4fa4-812c-b35ee1a9e29e |
+-----------+--------------------------------------+

Then I run this repeatedly :

 cinder backup-list | grep de3e9f5b-a628-4fa4-812c-b35ee1a9e29e

The output is at first :

| d9c49ba8-6614-42b6-b591-07ac378260a1 | de3e9f5b-a628-4fa4-812c-b35ee1a9e29e | creating | BackupTest | 10 | 0 | volumebackups |

After sometime the output changes to :

| d9c49ba8-6614-42b6-b591-07ac378260a1 | de3e9f5b-a628-4fa4-812c-b35ee1a9e29e | error | BackupTest | 10 | 0 | volumebackups |

On running cinder backup-show d9c49ba8-6614-42b6-b591-07ac378260a1, the output is :

+-----------------------+-------------------------------------------------------------------+
| Property              | Value                                                             |
+-----------------------+-------------------------------------------------------------------+
| availability_zone     | nova                                                              |
| container             | volumebackups                                                     |
| created_at            | 2017-07-14T03:26:54.000000                                        |
| data_timestamp        | 2017-07-14T03:26:54.000000                                        |
| description           | None                                                              |
| fail_reason           | Timed out waiting for a reply to message ID 3eb06b612efc4e8399a689|
                          1a3d6f78f7                                                        |
| has_dependent_backups | False                                                             |
| id                    | d9c49ba8-6614-42b6-b591-07ac378260a1                              |
| is_incremental        | False                                                             |
| name                  | BackupTest                                                        |
| object_count          | 0                                                                 |
| size                  | 10                                                                |
| snapshot_id           | None                                                              |
| status                | error                                                             |
| updated_at            | 2017-07-14T03:27:55.000000                                        |
| volume_id             | de3e9f5b-a628-4fa4-812c-b35ee1a9e29e                              |
+-----------------------+-------------------------------------------------------------------+

I cannot guess the origin of this problem as no log is created in controller, cinder or nova nodes. Please suggest a way so that I can create a valid backup of my instance.