Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

OpenSource Mano (OSM) & OpenStack: “The request you have made requires authentication. (HTTP 401)”

Hello,

Currently working on Newtorks Virtualization, I am trying to configure OpenStack and Open Source MANO to make them work together. I am following the OSM tutorial (https://osm.etsi.org/wikipub/index.php/OSM_Release_TWO). I have a problem at the step "Instantiating a NS". After clicking on Launch, I’ve got the following message:

VIM Exception vimconnUnexpectedResponse Unauthorized: The request you have made requires authentication.
(HTTP 401) (Request-ID: req-83c01de4-4942-414c-8431-73ee089dd1b6). 
(False, " Rollback fails to delete: ['network TASK.1498137381.233714 from VIM openstack-site2']")

I don't understand where it is coming from. When I am trying to connect in a navigator to the address I put when creating the datacenter (10.0.3.44:8447/v2.1), I get the same HTTP 401 error. This address is the one I found in the "API Access" section of the OpenStack UI for the compute service. I used it to create the datacenter in openmano:

openmano datacenter-create openstack-site http://10.0.3.44:8447/v2.1 --type openstack --description "OpenStack site"
openmano datacenter-attach openstack-site --user=admin --password=mypwd --vim-tenant-name=admin

Does anyone know what could be my problem?

Thank you.

OpenSource Mano (OSM) & OpenStack: “The request you have made requires authentication. (HTTP 401)”

Hello,

Currently working on Newtorks Virtualization, I am trying to configure OpenStack and Open Source MANO to make them work together. I am following the OSM tutorial (https://osm.etsi.org/wikipub/index.php/OSM_Release_TWO). I have a problem at the step "Instantiating a NS". After clicking on Launch, I’ve got the following message:

VIM Exception vimconnUnexpectedResponse Unauthorized: The request you have made requires authentication.
(HTTP 401) (Request-ID: req-83c01de4-4942-414c-8431-73ee089dd1b6). 
(False, " Rollback fails to delete: ['network TASK.1498137381.233714 from VIM openstack-site2']")

I don't understand where it is coming from. When I am trying to connect in a navigator browser to the address I put when creating the datacenter (10.0.3.44:8447/v2.1), I get the same HTTP 401 error. This address is the one I found in the "API Access" section of the OpenStack UI for the compute service. I used it to create the datacenter in openmano:

openmano datacenter-create openstack-site http://10.0.3.44:8447/v2.1 --type openstack --description "OpenStack site"
openmano datacenter-attach openstack-site --user=admin --password=mypwd --vim-tenant-name=admin

Does anyone know what could be my problem?

Thank you.