Revision history [back]

click to hide/show revision 1
initial version

nova-status upgrade check fails

Hi, I'm using this guide https://docs.openstack.org/ocata to do an openstack installation. I've got a physical machine which is running kvm which is my nova compute and I've got an instance which is running the control node.

nova-status --debug upgrade check

Results in following error:

    Error:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 456, in main
        ret = fn(*fn_args, **fn_kwargs)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 386, in check
        result = func(self)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 201, in _check_placement
        versions = self._placement_get("/")
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 189, in _placement_get
        return client.get(path, endpoint_filter=ks_filter).json()
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 758, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 655, in request
    raise exceptions.from_response(resp, method, url)
InternalServerError: Internal Server Error (HTTP 500)

This seems to be the corresponding log

2017-06-16 15:59:55.802 1153 WARNING keystoneauth.identity.generic.base [-] Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
mod_wsgi (pid=1153): Exception occurred processing WSGI script '/usr/bin/nova-placement-api'.
Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/oslo_middleware/request_id.py", line 37, in __call__
        response = req.get_response(self.application)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
        application, catch_exc_info=False)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in call_application
        app_iter = application(self.environ, start_response)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
        response = self.process_request(req)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
        resp = super(AuthProtocol, self).process_request(request)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 435, in _do_fetch_token
        data = self.fetch_token(token, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 762, in fetch_token
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 217, in verify_token
        auth_ref = self._request_strategy.verify_token(
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 168, in _request_strategy
        strategy_class = self._get_strategy_class()
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 190, in _get_strategy_class
        if self._adapter.get_endpoint(version=klass.AUTH_VERSION):
      File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in get_endpoint
        return self.session.get_endpoint(auth or self.auth, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in get_endpoint
        return auth.get_endpoint(self, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 212, in get_endpoint
        service_catalog = self.get_access(session).service_catalog
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
        self.auth_ref = self.get_auth_ref(session)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 196, in get_auth_ref
        self._plugin = self._do_create_plugin(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 191, in _do_create_plugin
    raise exceptions.DiscoveryFailure('Could not determine a suitable URL '
DiscoveryFailure: Could not determine a suitable URL for the plugin

If additional logs are needed please tell me.

Thanks in advance and regards, Uli

nova-status upgrade check fails

Hi, I'm using this guide https://docs.openstack.org/ocata to do an openstack installation. I've got a physical machine which is running kvm which is my nova compute and I've got an instance which is running the control node.

nova-status --debug upgrade check

Results in following error:

    Error:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 456, in main
        ret = fn(*fn_args, **fn_kwargs)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 386, in check
        result = func(self)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 201, in _check_placement
        versions = self._placement_get("/")
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 189, in _placement_get
        return client.get(path, endpoint_filter=ks_filter).json()
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 758, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 655, in request
    raise exceptions.from_response(resp, method, url)
InternalServerError: Internal Server Error (HTTP 500)

This seems to be the corresponding log

2017-06-16 15:59:55.802 1153 WARNING keystoneauth.identity.generic.base [-] Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
mod_wsgi (pid=1153): Exception occurred processing WSGI script '/usr/bin/nova-placement-api'.
Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/oslo_middleware/request_id.py", line 37, in __call__
        response = req.get_response(self.application)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
        application, catch_exc_info=False)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in call_application
        app_iter = application(self.environ, start_response)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
        response = self.process_request(req)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
        resp = super(AuthProtocol, self).process_request(request)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 435, in _do_fetch_token
        data = self.fetch_token(token, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 762, in fetch_token
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 217, in verify_token
        auth_ref = self._request_strategy.verify_token(
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 168, in _request_strategy
        strategy_class = self._get_strategy_class()
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 190, in _get_strategy_class
        if self._adapter.get_endpoint(version=klass.AUTH_VERSION):
      File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in get_endpoint
        return self.session.get_endpoint(auth or self.auth, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in get_endpoint
        return auth.get_endpoint(self, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 212, in get_endpoint
        service_catalog = self.get_access(session).service_catalog
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
        self.auth_ref = self.get_auth_ref(session)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 196, in get_auth_ref
        self._plugin = self._do_create_plugin(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 191, in _do_create_plugin
    raise exceptions.DiscoveryFailure('Could not determine a suitable URL '
DiscoveryFailure: Could not determine a suitable URL for the plugin

On control I find this:

10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "POST /resource_providers HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"
10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "GET /resource_providers/c9aaae1a-c3fa-4752-a986-d212854e9517/allocations HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"

If additional logs are needed please tell me.

Thanks in advance and regards, Uli

nova-status upgrade check fails

Hi, I'm using this guide https://docs.openstack.org/ocata to do an openstack installation. I've got a physical machine which is running kvm which is my nova compute and I've got an instance which is running the control node.

nova-status --debug upgrade check

Results in following error:

    Error:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 456, in main
        ret = fn(*fn_args, **fn_kwargs)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 386, in check
        result = func(self)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 201, in _check_placement
        versions = self._placement_get("/")
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 189, in _placement_get
        return client.get(path, endpoint_filter=ks_filter).json()
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 758, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 655, in request
    raise exceptions.from_response(resp, method, url)
InternalServerError: Internal Server Error (HTTP 500)

This seems to be the corresponding log

2017-06-16 15:59:55.802 1153 WARNING keystoneauth.identity.generic.base [-] Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
mod_wsgi (pid=1153): Exception occurred processing WSGI script '/usr/bin/nova-placement-api'.
Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/oslo_middleware/request_id.py", line 37, in __call__
        response = req.get_response(self.application)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
        application, catch_exc_info=False)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in call_application
        app_iter = application(self.environ, start_response)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
        response = self.process_request(req)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
        resp = super(AuthProtocol, self).process_request(request)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 435, in _do_fetch_token
        data = self.fetch_token(token, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 762, in fetch_token
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 217, in verify_token
        auth_ref = self._request_strategy.verify_token(
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 168, in _request_strategy
        strategy_class = self._get_strategy_class()
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 190, in _get_strategy_class
        if self._adapter.get_endpoint(version=klass.AUTH_VERSION):
      File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in get_endpoint
        return self.session.get_endpoint(auth or self.auth, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in get_endpoint
        return auth.get_endpoint(self, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 212, in get_endpoint
        service_catalog = self.get_access(session).service_catalog
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
        self.auth_ref = self.get_auth_ref(session)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 196, in get_auth_ref
        self._plugin = self._do_create_plugin(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 191, in _do_create_plugin
    raise exceptions.DiscoveryFailure('Could not determine a suitable URL '
DiscoveryFailure: Could not determine a suitable URL for the plugin

On control I find this:

10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "POST /resource_providers HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"
10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "GET /resource_providers/c9aaae1a-c3fa-4752-a986-d212854e9517/allocations HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"

10.0.0.1 is my nova compute.

If additional logs are needed please tell me.

Thanks in advance and regards, Uli

nova-status upgrade check fails

Hi, I'm using this guide https://docs.openstack.org/ocata to do an openstack installation. I've got a physical machine which is running kvm which is my nova compute and I've got an instance which is running the control node.

nova-status --debug upgrade check

Results in following error:

    Error:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 456, in main
        ret = fn(*fn_args, **fn_kwargs)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 386, in check
        result = func(self)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 201, in _check_placement
        versions = self._placement_get("/")
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 189, in _placement_get
        return client.get(path, endpoint_filter=ks_filter).json()
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 758, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 655, in request
    raise exceptions.from_response(resp, method, url)
InternalServerError: Internal Server Error (HTTP 500)

This seems to be the corresponding log

2017-06-16 15:59:55.802 1153 WARNING keystoneauth.identity.generic.base [-] Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
mod_wsgi (pid=1153): Exception occurred processing WSGI script '/usr/bin/nova-placement-api'.
Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/oslo_middleware/request_id.py", line 37, in __call__
        response = req.get_response(self.application)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
        application, catch_exc_info=False)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in call_application
        app_iter = application(self.environ, start_response)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
        response = self.process_request(req)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
        resp = super(AuthProtocol, self).process_request(request)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 435, in _do_fetch_token
        data = self.fetch_token(token, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 762, in fetch_token
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 217, in verify_token
        auth_ref = self._request_strategy.verify_token(
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 168, in _request_strategy
        strategy_class = self._get_strategy_class()
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 190, in _get_strategy_class
        if self._adapter.get_endpoint(version=klass.AUTH_VERSION):
      File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in get_endpoint
        return self.session.get_endpoint(auth or self.auth, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in get_endpoint
        return auth.get_endpoint(self, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 212, in get_endpoint
        service_catalog = self.get_access(session).service_catalog
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
        self.auth_ref = self.get_auth_ref(session)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 196, in get_auth_ref
        self._plugin = self._do_create_plugin(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 191, in _do_create_plugin
    raise exceptions.DiscoveryFailure('Could not determine a suitable URL '
DiscoveryFailure: Could not determine a suitable URL for the plugin

On control I find this:

10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "POST /resource_providers HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"
10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "GET /resource_providers/c9aaae1a-c3fa-4752-a986-d212854e9517/allocations HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"

10.0.0.1 is my nova compute.

If additional logs are needed please tell me.

Thanks in advance and regards, Uli

nova-status upgrade check fails

Hi, I'm using this guide https://docs.openstack.org/ocata to do an openstack installation. I've got a physical machine which is running kvm which is my nova compute and I've got an instance which is running the control node.

nova-status --debug upgrade check

Results in following error:

    Error:
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 456, in main
        ret = fn(*fn_args, **fn_kwargs)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 386, in check
        result = func(self)
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 201, in _check_placement
        versions = self._placement_get("/")
      File "/usr/lib/python2.7/site-packages/nova/cmd/status.py", line 189, in _placement_get
        return client.get(path, endpoint_filter=ks_filter).json()
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 758, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/site-packages/positional/__init__.py", line 101, in inner
    return wrapped(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 655, in request
    raise exceptions.from_response(resp, method, url)
InternalServerError: Internal Server Error (HTTP 500)

This seems to be the corresponding log

2017-06-16 15:59:55.802 1153 WARNING keystoneauth.identity.generic.base [-] Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
mod_wsgi (pid=1153): Exception occurred processing WSGI script '/usr/bin/nova-placement-api'.
Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/oslo_middleware/request_id.py", line 37, in __call__
        response = req.get_response(self.application)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1299, in send
        application, catch_exc_info=False)
      File "/usr/lib/python2.7/site-packages/webob/request.py", line 1263, in call_application
        app_iter = application(self.environ, start_response)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 130, in __call__
        resp = self.call_func(req, *args, **self.kwargs)
      File "/usr/lib/python2.7/site-packages/webob/dec.py", line 195, in call_func
        return self.func(req, *args, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 332, in __call__
        response = self.process_request(req)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 623, in process_request
        resp = super(AuthProtocol, self).process_request(request)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 405, in process_request
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 435, in _do_fetch_token
        data = self.fetch_token(token, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/__init__.py", line 762, in fetch_token
        allow_expired=allow_expired)
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 217, in verify_token
        auth_ref = self._request_strategy.verify_token(
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 168, in _request_strategy
        strategy_class = self._get_strategy_class()
      File "/usr/lib/python2.7/site-packages/keystonemiddleware/auth_token/_identity.py", line 190, in _get_strategy_class
        if self._adapter.get_endpoint(version=klass.AUTH_VERSION):
      File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 176, in get_endpoint
        return self.session.get_endpoint(auth or self.auth, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 856, in get_endpoint
        return auth.get_endpoint(self, **kwargs)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 212, in get_endpoint
        service_catalog = self.get_access(session).service_catalog
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/base.py", line 136, in get_access
        self.auth_ref = self.get_auth_ref(session)
      File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 196, in get_auth_ref
        self._plugin = self._do_create_plugin(session)
  File "/usr/lib/python2.7/site-packages/keystoneauth1/identity/generic/base.py", line 191, in _do_create_plugin
    raise exceptions.DiscoveryFailure('Could not determine a suitable URL '
DiscoveryFailure: Could not determine a suitable URL for the plugin

On control I find this:

10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "POST /resource_providers HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"
10.0.0.1 - - [19/Jun/2017:08:23:21 +0200] "GET /resource_providers/c9aaae1a-c3fa-4752-a986-d212854e9517/allocations HTTP/1.1" 500 527 "-" "nova-compute keystoneauth1/2.18.0 python-requests/2.11.1 CPython/2.7.5"

10.0.0.1 is my nova compute.

If additional logs are needed please tell me.

Thanks in advance and regards, Uli