Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Internet is not working After physical interface mapping to bridge br-int using ODL_MODE=allinone

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not working After physical interface mapping to bridge br-int using ODL_MODE=allinone

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not working After physical interface mapping to bridge br-int using ODL_MODE=allinone

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not working reachable After physical interface mapping to bridge br-int using ODL_MODE=allinonewith Openstack+Opendaylight[ODL_MODE=allinone] integrated

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not reachable After physical interface mapping to bridge br-int with Openstack+Opendaylight[ODL_MODE=allinone] integrated

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not reachable After physical interface mapping to bridge br-int with Openstack+Opendaylight[ODL_MODE=allinone] integrated

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not reachable After physical interface mapping to bridge br-int with Openstack+Opendaylight[ODL_MODE=allinone] integrated

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh

Internet is not reachable After physical interface mapping to bridge br-int with Openstack+Opendaylight[ODL_MODE=allinone] integrated

Hi All,

Im trying to bring up devstack+opendaylight integrated on my laptop with ODL_MODE=allinone.

Issue is when the physical interface eth0 is mapped to bridge br-int which happens while running ./stack.sh as per the local.conf setting (ODL_PROVIDER_MAPPINGS=public:eth0) the network connectivity on the host machine is lost & ./stack.sh fails due to unavailability of internet.

Details Below:

Laptop OS: Ubuntu 16.04 LTS

Devstack: Master Branch

Opendaylight: Boron (distribution-karaf-0.7.0-20170503.100054-271.zip)

OVS version: 2.6.1

My Requirement: Creation of Openstack instances & internet reachability from VM's

Local.conf file:

[[local|localrc]]

ADMIN_PASSWORD=admin

DATABASE_PASSWORD=stackdb

RABBIT_PASSWORD=stackqueue

SERVICE_PASSWORD=$ADMIN_PASSWORD

LOGDIR=$DEST/logs

LOGFILE=$DEST/logs/stack.sh.log

LOGDAYS=2

OFFLINE=False

RECLONE=no

HOST_IP=10.132.232.89

SERVICE_HOST=$HOST_IP

Q_HOST=$SERVICE_HOST

Enable heat services

enable_service h-eng h-api h-api-cfn h-api-cw

Enable heat plugin

enable_plugin heat git://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"

IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"

IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"

IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

Neutron

disable_service n-net

enable_service q-svc q-dhcp q-meta neutron

enable_service odl-server

Enable neutron ODL plugin

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl

Q_PLUGIN=ml2

NEUTRON_CREATE_INITIAL_NETWORKS=False

ODL_MODE=allinone

Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger

ODL_PROVIDER_MAPPINGS=public:eth0

SKIP_OVS_INSTALL=True

[[post-config|$NEUTRON_CONF]]

[DEFAULT]

service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]

[agent]

minimize_polling=True

Output of "sudo ovs-vsctl show"

00b40991-f38b-40bb-9ce9-318764b7c395

Manager "tcp:10.132.232.89:6640"

    is_connected: true

Bridge br-ex

    Port br-ex

        Interface br-ex

            type: internal

Bridge br-int

    Controller "tcp:10.132.232.89:6653"

        is_connected: true

    fail_mode: secure

    Port br-int

        Interface br-int

            type: internal

    Port "eth0"

        Interface "eth0"

ovs_version: "2.6.1"

ifconfig output:

stack@controller:~/openstack-repo/devstack$ ifconfig

eth0 Link encap:Ethernet HWaddr 18:03:73:3a:89:41

      inet addr:10.132.232.89  Bcast:10.132.232.127  Mask:255.255.255.192

      inet6 addr: fe80::26f1:77c0:8c5e:59ac/64 Scope:Link

      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

      RX packets:44572 errors:0 dropped:0 overruns:0 frame:0

      TX packets:31104 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:36314962 (36.3 MB)  TX bytes:3759853 (3.7 MB)

      Interrupt:20 Memory:f7c00000-f7c20000

lo Link encap:Local Loopback

      inet addr:127.0.0.1  Mask:255.0.0.0

      inet6 addr: ::1/128 Scope:Host

      UP LOOPBACK RUNNING  MTU:65536  Metric:1

      RX packets:257693 errors:0 dropped:0 overruns:0 frame:0

      TX packets:257693 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1

      RX bytes:399639406 (399.6 MB)  TX bytes:399639406 (399.6 MB)

virbr0 Link encap:Ethernet HWaddr 00:00:00:00:00:00

      inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0

      UP BROADCAST MULTICAST  MTU:1500  Metric:1

      RX packets:0 errors:0 dropped:0 overruns:0 frame:0

      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

      collisions:0 txqueuelen:1000

      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

After eth0 is mapped to bridge br-int, internet is not available on the host machine & hence ./stack.sh errors are seen.

./stack.sh fails during running below:

2017-05-31 11:14:47.818 | ++lib/tempest:configure_tempest:556 [[ False != \T\r\u\e ]]

2017-05-31 11:14:47.823 | ++lib/tempest:configure_tempest:557 tox -revenv-tempest --notest

2017-05-31 11:14:48.880 | venv-tempest recreate: /opt/stack/tempest/.tox/tempest

Please let me know if anything Im missing here. Why the internet is not reachable on the host machine once physical interface is mapped to br-int bridge.

Thanks

-Suresh