Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

how to set up openstack local.con in virtual box

Hi all, I installed Openstack Mitaka using devstack for many times and there were always some bugs. I think it has something to do with the initial network set up.

For virtual box, I added a new host-only network "vboxnet0" with configures:

IPv4:192.168.56.1

IPv4 network mask: 255.255.255.0

Disable DHCP server (the NAT network enabled DHCP)

And for the virtual machine I created, I used Ubuntu 14.04 Desktop, with network configures:

Adapter 1: NAT

Adapter 2: Host-only adapter - vboxnet0.

Then after virtual machine initialisation and basic update, I got:

>>ifconfig
lo - 127.0.0., Mask: 255.0.0.0, scope: host
eth0 - 10.0.2.15, Mask: 255.255.255.0, scope: link
ether - 0.0.0.1, Mask: 0.0.0.1, scope: link

So how should I set the devstack/local.conf file? I tried to install devstack without setting it but after I created an instance, I could't console into the instance. And also the instance got an IP like 174.24.4.x, which is quite weird because I though it should be something like 10.0.0.x.

how to set up openstack local.con in virtual box

Hi all, I installed Openstack Mitaka using devstack for many times and there were always some bugs. I think it has something to do with the initial network set up.

For virtual box, I added a new host-only network "vboxnet0" with configures:

IPv4:192.168.56.1

IPv4 network mask: 255.255.255.0

Disable DHCP server (the NAT network enabled DHCP)

And for the virtual machine I created, I used Ubuntu 14.04 Desktop, with network configures:

Adapter 1: NAT

Adapter 2: Host-only adapter - vboxnet0.

Then after virtual machine initialisation and basic update, I got:

>>ifconfig
lo - 127.0.0., Mask: 255.0.0.0, scope: host
eth0 - 10.0.2.15, Mask: 255.255.255.0, scope: link
ether - 0.0.0.1, eth1 - 0.0.0.1., Mask: 0.0.0.1, 0.0.0.0, scope: link

So how should I set the devstack/local.conf file? I tried to install devstack without setting it but after I created an instance, I could't console into the instance. And also the instance got an IP like 174.24.4.x, which is quite weird because I though it should be something like 10.0.0.x.

how to set up openstack local.con in virtual box

Hi all, I installed Openstack Mitaka using devstack for many times and there were always some bugs. I think it has something to do with the initial network set up.

For virtual box, I added a new host-only network "vboxnet0" with configures:

IPv4:192.168.56.1

IPv4 network mask: 255.255.255.0

Disable DHCP server (the NAT network enabled DHCP)

And for the virtual machine I created, I used Ubuntu 14.04 Desktop, with network configures:

Adapter 1: NAT

Adapter 2: Host-only adapter - vboxnet0.

Then after virtual machine initialisation and basic update, I got:

>>ifconfig
lo - 127.0.0., Mask: 255.0.0.0, scope: host
eth0 - 10.0.2.15, Mask: 255.255.255.0, scope: link
eth1 - 0.0.0.1., Mask: 0.0.0.0, scope: link

So how should I set the devstack/local.conf file? I tried to install devstack without setting it but after I created an instance, I could't console into the instance. And also the instance got an IP like 174.24.4.x, which is quite weird because I though thought it should be something like 10.0.0.x.

how to set up openstack local.con in virtual box

Hi all, I installed Openstack Mitaka using devstack for many times and there were always some bugs. I think it has something to do with the initial network set up.

For virtual box, I added a new host-only network "vboxnet0" with configures:

IPv4:192.168.56.1

IPv4 network mask: 255.255.255.0

Disable DHCP server (the NAT network enabled DHCP)

And for the virtual machine I created, I used Ubuntu 14.04 Desktop, with network configures:

Adapter 1: NAT

Adapter 2: Host-only adapter - vboxnet0.

Then after virtual machine initialisation and basic update, I got:

>>ifconfig
lo - 127.0.0., Mask: 255.0.0.0, scope: host
eth0 - 10.0.2.15, Mask: 255.255.255.0, scope: link
eth1 - 0.0.0.1., Mask: 0.0.0.0, scope: link

So how should I set the devstack/local.conf file? I tried to install devstack without setting it but after I created an instance, I could't console into the instance. And also the instance got an IP like 174.24.4.x, which is quite weird because I thought it should be something like 10.0.0.x.