Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to increase default timeout value of LB ?

I am seeing that the default timeout comes out to be 50000ms, for server and the client .. I am using HAPROXY , and below is how my config for LBAAS looks -

cat conf global daemon user nobody group nobody log /dev/log local0 log /dev/log local1 notice stats socket /var/lib/neutron/lbaas/9851517f-df80-415e-a211-17bc5290e5a6/sock mode 0666 level user defaults log global retries 3 option redispatch timeout connect 5000 timeout client 50000 timeout server 50000 frontend 1aa92b4b-7e51-48bb-b6b6-16efe1234b78 option tcplog bind IP:PORT mode tcp default_backend 9851517f-df80-415e-a211-17bc5290e5a6 backend 9851517f-df80-415e-a211-17bc5290e5a6 mode tcp balance roundrobin server 295c5b8a-885f-48b6-98ca-5a99c1b93dd3 IP:PORT weight 1 server 2e3b4e05-43d1-4cba-bb6d-c2edc3c9acfc IP:PORT weight 1

I am using Juno .. I have been searching this a bit, and my app team is complaining about, a large query, where this timeout is not sufficient ..

How to increase default timeout value of LB ?

I am seeing that the default timeout comes out to be 50000ms, for server and the client .. I am using HAPROXY , and below is how my config for LBAAS looks -

cat conf global daemon user nobody group nobody log /dev/log local0 log /dev/log local1 notice stats socket /var/lib/neutron/lbaas/9851517f-df80-415e-a211-17bc5290e5a6/sock mode 0666 level user defaults log global retries 3 option redispatch timeout connect 5000 timeout client 50000 timeout server 50000 frontend 1aa92b4b-7e51-48bb-b6b6-16efe1234b78 option tcplog bind IP:PORT mode tcp default_backend 9851517f-df80-415e-a211-17bc5290e5a6 backend 9851517f-df80-415e-a211-17bc5290e5a6 mode tcp balance roundrobin server 295c5b8a-885f-48b6-98ca-5a99c1b93dd3 IP:PORT weight 1 server 2e3b4e05-43d1-4cba-bb6d-c2edc3c9acfc IP:PORT weight 1

I am using Juno .. I have been searching this a bit, and my app team is complaining about, a large query, where this timeout is not sufficient .. ..