Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Not able to see l3-agent in neutron agent-list

Actually we are configuring liberty all-in-one setup according to openstack-liberty . We have an issue while configuring neutron, neutron agent-list doesn't show l3-agent. neutron agent-list +--------------------------------------+--------------------+--------+-------+----------------+---------------------------+ | id | agent_type | host | alive | admin_state_up | binary | +--------------------------------------+--------------------+--------+-------+----------------+---------------------------+ | c9cc7536-a68b-4e55-a7f6-10c8196512cb | Metadata agent | ubuntu | :-) | True | neutron-metadata-agent | | dfa45b22-ddfb-46a4-9258-9c94bab86c77 | Open vSwitch agent | ubuntu | :-) | True | neutron-openvswitch-agent | | f08ba917-84c6-491a-8b8f-c2bcb9e7421a | DHCP agent | ubuntu | :-) | True | neutron-dhcp-agent | +--------------------------------------+--------------------+--------+-------+----------------+------------------------

And if we restart l3-agent service the output is like: root@ubuntu:~# service neutron-l3-agent restart stop: Unknown instance: neutron-l3-agent start/running, process 15352

If I stop and start the services seperately it runs. But, it starts and be active only for 3-5 secs again it stops. How to deal with this issue??? please help

Not able to see l3-agent in neutron agent-list

Actually we are configuring liberty all-in-one setup according to openstack-liberty . We have an issue while configuring neutron, neutron agent-list doesn't show l3-agent. l3-agent.

neutron agent-list
+--------------------------------------+--------------------+--------+-------+----------------+---------------------------+
| id                                   | agent_type         | host   | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+--------+-------+----------------+---------------------------+
| c9cc7536-a68b-4e55-a7f6-10c8196512cb | Metadata agent     | ubuntu | :-)   | True           | neutron-metadata-agent    |
| dfa45b22-ddfb-46a4-9258-9c94bab86c77 | Open vSwitch agent | ubuntu | :-)   | True           | neutron-openvswitch-agent |
| f08ba917-84c6-491a-8b8f-c2bcb9e7421a | DHCP agent         | ubuntu | :-)   | True           | neutron-dhcp-agent        |
+--------------------------------------+--------------------+--------+-------+----------------+------------------------

+--------------------------------------+--------------------+--------+-------+----------------+------------------------

And if we restart l3-agent service the output is like: like:

root@ubuntu:~# service neutron-l3-agent restart
stop: Unknown instance:
neutron-l3-agent start/running, process 15352

15352

If I stop and start the services seperately it runs. But, it starts and be active only for 3-5 secs again it stops. How to deal with this issue??? please help