Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Can't access VMs from host

Hello,

I intsalled Devstack to test Sahara and i'm having problems with networking. I can't ping or ssh from my host to the VMs, to both the public and private IPs. From the VMs I can only connect to other VMs, and not outside. This is preventing me from creating Sahara clusters, but also from getting normal VMs, like the default cirros images, to work. Here's the configuration: local.conf

[[local|localrc]]
HOST_IP=10.100.1.101
FLOATING_RANGE=10.100.2.224/27
FIXED_RANGE=10.11.12.0/24
FIXED_NETWORK_SIZE=256
FLAT_INTERFACE=enp0s8
ADMIN_PASSWORD=nova
DATABASE_PASSWORD=nova
RABBIT_PASSWORD=nova
SERVICE_PASSWORD=$ADMIN_PASSWORD
NOVNC_BRANCH=v0.6.0
LOGFILE=$DEST/logs/stack.sh.log
LOGDAYS=2
SWIFT_HASH=66a3d6b56c1f479c8b4e70ab5c2000f5
SWIFT_REPLICAS=1
SWIFT_DATA_DIR=$DEST/data
enable_service heat h-api h-api-cfn h-api-cw h-eng
enable_plugin sahara git://git.openstack.org/openstack/sahara stable/ocata
enable_plugin heat https://git.openstack.org/openstack/heat stable/ocata
enable_plugin sahara-dashboard git://git.openstack.org/openstack/sahara-dashboard stable/ocata

Interfaces

auto lo
iface lo inet loopback
source /etc/network/interfaces.d/*.cfg
auto enp0s8
iface enp0s8 inet static
      address 10.100.1.101
      netmask 255.255.255.0
auto enp0s9
iface enp0s9 inet static
      address 10.100.2.101
      netmask 255.255.255.0

Default security group

Direction   Ether Type  IP Protocol Port Range  Remote IP Prefix    Remote Security Group
Egress      IPv4            Any         Any         0.0.0.0/0           -
Ingress     IPv4            Any         Any         -               default
Egress      IPv6            Any         Any         ::/0                -
Ingress     IPv6            Any         Any         -               default
Egress      IPv4            ICMP        Any         0.0.0.0/0           -
Ingress     IPv4            ICMP        Any         0.0.0.0/0           -
Ingress     IPv4            TCP         1 - 65535   0.0.0.0/0           -
Egress      IPv4            TCP         1 - 65535   0.0.0.0/0           -

Please help me, I have no idea why this is not working, i've basically tried everything.