Revision history [back]

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

Here is my nova.conf file http://paste.openstack.org/show/605630/

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/http://paste.openstack.org/show/605630/ and errors from nova-conductor.log http://paste.openstack.org/show/605649/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/ and errors from nova-conductor.log http://paste.openstack.org/show/605649/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/ and errors from nova-conductor.log http://paste.openstack.org/show/605649/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

edit:

This is what probably causing an issue no hypervisors available in Nova, still I do not know how to solve this problem.

nova hypervisor-list http://paste.openstack.org/show/605781/

Newton Launching a new Instance. - "No valid host was found. There are not enough hosts available."

I am running Ubuntu 16.04 and OpenStack Newton. I have one server running as controller node.

When I am trying to launch new instance using CLI or horizon dashboard. An error occurs

No valid host was found. There are not enough hosts available.

I was trying to change ram and vCPU allocation ratio but it doesn't seems like it have any effect on it.

I think this might be something wrong with my Nova configuration. Here are my logs:

Error from horizon dashboard http://paste.openstack.org/show/605628/

This is what I see when I am issuing command nova hypervisor-stats It seems like it does not see any available resources. Which I should have enough for at least small flavor instance. http://paste.openstack.org/show/605629/

However my nova quota-show proves I have plenty of resources to use http://paste.openstack.org/show/605632/

Here is my nova.conf file http://paste.openstack.org/show/605630/ and errors from nova-conductor.log http://paste.openstack.org/show/605649/

Also nova-scheduler.log file http://paste.openstack.org/show/605647/

This is also propably realted to the issue when I am accessing "Admin/System/All Hypervisors" via horizon dashboard the list is empty. I am not sure if I should see anything there?

edit:

This is what probably causing an issue no hypervisors available in Nova, still I do not know how to solve this problem.

nova hypervisor-list http://paste.openstack.org/show/605781/