Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Openstack Ansible bootstrap script fails

I am very new to Ansible (although I have experience in Openstack) and I am trying to deploy Openstack Newton multinode architecture (deployment, infra, compute) from this link. But the installation fails in the first step i.e. while running the Ansible bootstrap script. I have setup the br-mgmt bridge. I don't know where the issue lies, because I don't see any such errors in logs. I have setup the vlan segment on my interface port ens33 and attached the bridge to this logical interface. There are no extra bridges required on the deployment node, right? Is the problem being caused by improper networking setup of the node? I am using a hub(non-programmable) connected to a router as the network. Kindly help.

Openstack Ansible bootstrap script fails

I am very new to Ansible (although I have experience in Openstack) and I am trying to deploy Openstack Newton multinode architecture (deployment, infra, compute) from this link. But the installation fails in the first step i.e. while running the Ansible bootstrap script. I have setup the br-mgmt bridge. I don't know where the issue lies, because I don't see any such errors in logs. I have setup the vlan segment on my interface port ens33 and attached the bridge to this logical interface. There are no extra bridges required on the deployment node, right? Is the problem being caused by improper networking setup of the node? I am using a hub(non-programmable) connected to a router as the network. The error :

[WARNING]: - galera_client was NOT installed successfully: - command git clone https://git.openstack.org/openstack/openstack-ansible-galera_client galera_client failed in directory /tmp/tmpp7Izwv (rc=128)

Kindly help.