Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Unable to login with admin after fresh installation of Dashboard

Hi guys After I installed the dashboard on 2 Ubuntu16 nodes, I can login the web page dashboard.

All the instructions is followed from

https://docs.openstack.org/project-install-guide/ocata/ubuntu-services.html

nova-manage ---version===15.0.1

Checking on apache error log is like this: [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x

There were plenty of this error after freshing web page. I didn't change admin account password, when I check openstack status, like openstack user list, etc. It will show the directly result. In my case, I believe the keystone service is working, for dashborad is granted all host visit.

So I got 2 concerns: 1. how to fix it :) 2 I found after sync with keystone local database, I found it can't find keystone service, which I can't restart it both /etc/init.d/keystone (cannot find keystone service name) and systemctl restart keystone(no keytone).

Any help will be appreciated.

Unable to login with admin after fresh installation of Dashboard

Hi guys After I installed the dashboard on 2 Ubuntu16 nodes, I can login the web page dashboard.

All the instructions is followed from

https://docs.openstack.org/project-install-guide/ocata/ubuntu-services.html

nova-manage ---version===15.0.1

Building dependency tree
Reading state information... Done

keystone is already the newest version (2:11.0.0-0ubuntu1.1~cloud0).

Checking on apache error log is like this: [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x

There were plenty of this error after freshing web page. I didn't change admin account password, when I check openstack status, like openstack user list, etc. It will show the directly result. In my case, I believe the keystone service is working, for dashborad is granted all host visit.

So I got 2 concerns: 1. how to fix it :) 2 I found after sync with keystone local database, I found it can't find keystone service, which I can't restart it both /etc/init.d/keystone (cannot find keystone service name) and systemctl restart keystone(no keytone).

Any help will be appreciated.

Unable to login with admin after fresh installation of Dashboard

Hi guys After I installed the dashboard on 2 Ubuntu16 nodes, I can login the web page dashboard.

All the instructions is followed from

https://docs.openstack.org/project-install-guide/ocata/ubuntu-services.html nova-manage ---version===15.0.1

Building dependency tree
Reading state information... Done

keystone is already the newest version (2:11.0.0-0ubuntu1.1~cloud0).

Checking on apache error log is like this: [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x

There were plenty of this error after freshing web page. I didn't change admin account password, when I check openstack status, like openstack user list, etc. It will show the directly result. In my case, I believe the keystone service is working, for dashborad is granted all host visit.

So I got 2 concerns: 1. how to fix it :) 2 I found after sync with keystone local database, I found it can't find keystone service, which I can't restart it both /etc/init.d/keystone (cannot find keystone service name) and systemctl restart keystone(no keytone).

Any help will be appreciated.

Unable to login with admin after fresh installation of Dashboard

Hi guys After I installed the dashboard on 2 Ubuntu16 nodes, I can login the web page dashboard.

dashboard. All the instructions is followed from

https://docs.openstack.org/project-install-guide/ocata/ubuntu-services.html nova-manage ---version===15.0.1

---version===15.0.1 keystone is already the newest version (2:11.0.0-0ubuntu1.1~cloud0).

(2:11.0.0-0ubuntu1.1~cloud0)

Checking on apache error log is like this: [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x [wsgi:error] [pid 21177:tid 140685076526848] Login failed for user "admin", remote address x.x.x.x

There were plenty of this error after freshing web page. I didn't change admin account password, when I check openstack status, like openstack user list, etc. It will show the directly result. In my case, I believe the keystone service is working, for dashborad is granted all host visit.

So I got 2 concerns: 1. how to fix it :) 2 I found after sync with keystone local database, I found it can't find keystone service, which I can't restart it both /etc/init.d/keystone (cannot find keystone service name) and systemctl restart keystone(no keytone).

Any help will be appreciated.