Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Openstack Mitaka configuring DVR

Hi all,

I've followed the Open vSwitch High availably using DVR guide (https://docs.openstack.org/ocata/networking-guide/deploy-ovs-ha-dvr.html#deploy-ovs-ha-dvr) At the point "Verify network operations" they say "On each compute node, verify creation of a qrouter namespace with the same ID." but in my case the qrouter is created in the network node and in only one of the compute node, is that normal, is there an error in the documentation?

Thanks.

Openstack Mitaka configuring DVR

Hi all,

I've followed the Open vSwitch High availably using DVR guide (https://docs.openstack.org/ocata/networking-guide/deploy-ovs-ha-dvr.html#deploy-ovs-ha-dvr) At the point "Verify network operations" they say "On each compute node, verify creation of a qrouter namespace with the same ID." but in my case the qrouter is created in the network node and in only one of the compute node, is that normal, is there an error in the documentation?

It's very what is happening with the router creation:

First of all, my cluster is a kvm virtualised cluster 1 controller/network node and 2 compute node.

when I create the first router and attach a network to it the situation is as follow:

a.- controller/network node

#> ip netns

Output:

snat-4f32a82f-ed71-4b54-b0df-b756d56683bd
qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd

b.- compute0

#> ip netns

Output:

none

c.- compute1

#> ip netns

Output:

qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd
qdhcp-94928584-c08a-4b26-a55e-8cc3368796fc

Then I've created a second router and attach another network to it the situation become as follow:

a.- controller/network node

#> ip netns

Output:

snat-99cd0074-bd08-4026-9523-8f375a062d23
qrouter-99cd0074-bd08-4026-9523-8f375a062d23
snat-4f32a82f-ed71-4b54-b0df-b756d56683bd
qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd

b.- compute0

#> ip netns

Output:

qrouter-99cd0074-bd08-4026-9523-8f375a062d23
qdhcp-d2a62d51-18e0-423c-865f-cf5b6b9be85c

c

.- compute1

#> ip netns

Output:

qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd
qdhcp-94928584-c08a-4b26-a55e-8cc3368796fc

This time the router was created in the controller/network node and in the compute0 node, so the first router was created in the controller/network node and in the compute1 node, the second router was created in the controller/network node and in the compute0 node.

Thanks.

Openstack Mitaka configuring DVR

Hi all,

I've followed the Open vSwitch High availably using DVR guide (https://docs.openstack.org/ocata/networking-guide/deploy-ovs-ha-dvr.html#deploy-ovs-ha-dvr) At the point "Verify network operations" they say "On each compute node, verify creation of a qrouter namespace with the same ID." but in my case the qrouter is created in the network node and in only one of the compute node, is that normal, is there an error in the documentation?

It's very what is happening with the router creation:

First of all, my cluster is a kvm virtualised cluster 1 controller/network node and 2 compute node.

when I create the first router and attach a network to it the situation is as follow:

a.- controller/network node

#> ip netns

Output:

snat-4f32a82f-ed71-4b54-b0df-b756d56683bd
qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd

b.- compute0

#> ip netns

Output:

none

c.- compute1

#> ip netns

Output:

qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd
qdhcp-94928584-c08a-4b26-a55e-8cc3368796fc

Then I've created a second router and attach another network to it the situation become as follow:

a.- controller/network node

#> ip netns

Output:

snat-99cd0074-bd08-4026-9523-8f375a062d23
qrouter-99cd0074-bd08-4026-9523-8f375a062d23
snat-4f32a82f-ed71-4b54-b0df-b756d56683bd
qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd

b.- compute0

#> ip netns

Output:

qrouter-99cd0074-bd08-4026-9523-8f375a062d23
qdhcp-d2a62d51-18e0-423c-865f-cf5b6b9be85c

c

.-

c.- compute1

#> ip netns

Output:

qrouter-4f32a82f-ed71-4b54-b0df-b756d56683bd
qdhcp-94928584-c08a-4b26-a55e-8cc3368796fc

This time the router was created in the controller/network node and in the compute0 node, so the first router was created in the controller/network node and in the compute1 node, the second router was created in the controller/network node and in the compute0 node.

Thanks.