Revision history [back]

click to hide/show revision 1
initial version

swift stat commad doesn't give proper response

When running command swift -V 2.0 -A $OS_AUTH_URL -U demo:admin -K $ADMINPASS stat to verify that Swift works properly, command stucks during execution. When used command with --debug found out that proxy server does reply with auth token, but then command stucks to following phase,

DEBUG:iso8601.iso8601:Parsed 2014-01-12T19:33:14Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'19', 'tz_hour': None, 'month': u'01', 'timezone': u'Z', 'second': u'14', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'day': u'12', 'minute': u'33'} with default timezone <iso8601.iso8601.utc object="" at="" 0xd87f90=""> DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None DEBUG:iso8601.iso8601:Got u'01' for 'month' with default None DEBUG:iso8601.iso8601:Got u'12' for 'day' with default None DEBUG:iso8601.iso8601:Got u'19' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'33' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'14' for 'second' with default None

Link to full output of the command (http://pastebin.ubuntu.com/6734582/)

swift stat commad doesn't give proper response

When Hi,

I have installed Swift to SLES 11 SP3 servers, now when I'm running command swift -V 2.0 -A $OS_AUTH_URL -U demo:admin -K $ADMINPASS stat to verify that Swift works properly, command stucks during execution. When used command with --debug found out that proxy server does reply with auth token, but then command stucks to following phase,

DEBUG:iso8601.iso8601:Parsed 2014-01-12T19:33:14Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'19', 'tz_hour': None, 'month': u'01', 'timezone': u'Z', 'second': u'14', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'day': u'12', 'minute': u'33'} with default timezone <iso8601.iso8601.utc object="" at="" 0xd87f90=""> DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None DEBUG:iso8601.iso8601:Got u'01' for 'month' with default None DEBUG:iso8601.iso8601:Got u'12' for 'day' with default None DEBUG:iso8601.iso8601:Got u'19' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'33' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'14' for 'second' with default None

Link to full output of the command (http://pastebin.ubuntu.com/6734582/)

Tried to see if either /var/logs/warnings or /var/logs/messages would containg any information, but it seems that Swift doesn't log anything there.

swift stat commad doesn't give proper response

Hi,

I have installed Swift to SLES 11 SP3 servers, now when I'm running command swift -V 2.0 -A $OS_AUTH_URL -U demo:admin -K $ADMINPASS stat to verify that Swift works properly, command stucks during execution. When used command with --debug found out that proxy server does reply with auth token, but then command stucks to following phase,

DEBUG:iso8601.iso8601:Parsed 2014-01-12T19:33:14Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'19', 'tz_hour': None, 'month': u'01', 'timezone': u'Z', 'second': u'14', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'day': u'12', 'minute': u'33'} with default timezone <iso8601.iso8601.utc object="" at="" 0xd87f90=""> DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None DEBUG:iso8601.iso8601:Got u'01' for 'month' with default None DEBUG:iso8601.iso8601:Got u'12' for 'day' with default None DEBUG:iso8601.iso8601:Got u'19' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'33' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'14' for 'second' with default None

Link to full output of the command (http://pastebin.ubuntu.com/6734582/)

Tried to see if either /var/logs/warnings or /var/logs/messages would containg any information, but it seems that Swift doesn't log anything there.any errors there-

Also few questions comes to my mind, first when ring creation is initiated, should it populate some kind of directory structure under /srv/node/<dev_name> ? And when storage nodes are set up, shoud one configure account-server.conf, container-server.conf and object-server.conf files? There wasn't any instructions for such action in deployment guide.

click to hide/show revision 4
No.4 Revision

swift stat commad doesn't give proper response

Hi,

I have installed Swift to SLES 11 SP3 servers, now when I'm running command swift -V 2.0 -A $OS_AUTH_URL -U demo:admin -K $ADMINPASS stat to verify that Swift works properly, command stucks during execution. When used command with --debug found out that proxy server does reply with auth token, but then command stucks to following phase,

DEBUG:iso8601.iso8601:Parsed 2014-01-12T19:33:14Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'19', 'tz_hour': None, 'month': u'01', 'timezone': u'Z', 'second': u'14', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'day': u'12', 'minute': u'33'} with default timezone <iso8601.iso8601.utc object="" at="" 0xd87f90="">
  <iso8601.iso8601.Utc object at 0xd87f90>
DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None
 DEBUG:iso8601.iso8601:Got u'01' for 'month' with default None
 DEBUG:iso8601.iso8601:Got u'12' for 'day' with default None
 DEBUG:iso8601.iso8601:Got u'19' for 'hour' with default None
 DEBUG:iso8601.iso8601:Got u'33' for 'minute' with default None
 DEBUG:iso8601.iso8601:Got u'14' for 'second' with default None

None

Link to full output of the command (http://pastebin.ubuntu.com/6734582/)

Tried to see if either /var/logs/warnings or /var/logs/messages would containg any information, but it seems that Swift doesn't log any errors there-

Also few questions comes to my mind, first when ring creation is initiated, should it populate some kind of directory structure under /srv/node/<dev_name> ? And when storage nodes are set up, shoud one configure account-server.conf, container-server.conf and object-server.conf files? There wasn't any instructions for such action in deployment guide.

swift stat commad doesn't give proper response

Hi,

I have installed Swift to SLES 11 SP3 servers, now when I'm running command swift -V 2.0 -A $OS_AUTH_URL -U demo:admin -K $ADMINPASS stat to verify that Swift works properly, command stucks during execution. When used command with --debug found out that proxy server does reply with auth token, but then command stucks to following phase,

DEBUG:iso8601.iso8601:Parsed 2014-01-12T19:33:14Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'19', 'tz_hour': None, 'month': u'01', 'timezone': u'Z', 'second': u'14', 'tz_minute': None, 'year': u'2014', 'separator': u'T', 'day': u'12', 'minute': u'33'} with default timezone <iso8601.iso8601.Utc object at 0xd87f90>
DEBUG:iso8601.iso8601:Got u'2014' for 'year' with default None
DEBUG:iso8601.iso8601:Got u'01' for 'month' with default None
DEBUG:iso8601.iso8601:Got u'12' for 'day' with default None
DEBUG:iso8601.iso8601:Got u'19' for 'hour' with default None
DEBUG:iso8601.iso8601:Got u'33' for 'minute' with default None
DEBUG:iso8601.iso8601:Got u'14' for 'second' with default None

Link to full output of the command (http://pastebin.ubuntu.com/6734582/)

Tried to see if either /var/logs/warnings or /var/logs/messages would containg any information, but it seems that Swift doesn't log any errors there-

Also few questions comes to my mind, first when ring creation is initiated, should it populate some kind of directory structure under /srv/node/<dev_name> ? And when storage nodes are set up, shoud one configure account-server.conf, container-server.conf and object-server.conf files? There wasn't any instructions for such action in deployment guide.