Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

br100 setup and nova fixed ip range

This is my situation:

  • An ESXi 5.0 Server (I'm doing a project for my BD);
  • A pool with 2 VM (1 controller node and 1 compute node)
  • Ubuntu 13.04 amd64 Server installed on both VM
  • The controller IP is 172.25.27.11
  • i've successfully setup keystone, glance and partially nova

My problem with nova is the creation of the br100 and the fixed range subnet. Inside the /etc/network/interfaces file i have:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto br100
iface br100 inet dhcp
bridge_ports eth0
bridge_stp off
bridge_fd 0
bridge_maxwait 0

inside the file /etc/nova/nova.conf i have:

# NETWORK
network_manger_nova=nova.network.manger.FlatDHCPManager
my_ip=172.25.27.11
fixed_range=172.25.27.0/24
public_interface=eth0
vlan_interface=eth0
flat_interface=eth0
flat_network_bridge=br100

I have also enabled ip forwarding inside /etc/sysctl.conf and i have set eth0 promisc with ip link set eth0 promisc on.

The cmd brctl show show:

bridge name      bridge id    STP enabled        interfaces
br100            8000.xxxx    no                 eth0

What i am doing wrong?

br100 setup and nova fixed ip range

This is my situation:

  • An ESXi 5.0 Server (I'm doing a project for my BD);
  • A pool with 2 VM (1 controller node and 1 compute node)
  • Ubuntu 13.04 amd64 Server installed on both VM
  • The controller IP is 172.25.27.11
  • i've successfully setup keystone, glance and partially nova

My problem with nova is the creation of the br100 and the fixed range subnet. Inside the /etc/network/interfaces file i have:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto br100
iface br100 inet dhcp
bridge_ports eth0
bridge_stp off
bridge_fd 0
bridge_maxwait 0

inside the file /etc/nova/nova.conf i have:

# NETWORK
network_manger_nova=nova.network.manger.FlatDHCPManager
my_ip=172.25.27.11
fixed_range=172.25.27.0/24
public_interface=eth0
vlan_interface=eth0
flat_interface=eth0
flat_network_bridge=br100

I have also enabled ip forwarding inside /etc/sysctl.conf and i have set eth0 promisc with ip link set eth0 promisc on.

The cmd brctl show show:

bridge name      bridge id    STP enabled        interfaces
br100            8000.xxxx    no                 eth0

What i am doing wrong?