Revision history [back]

click to hide/show revision 1
initial version

Devstack: Invalid credentials after reboot. Keyostone error 404

I am trying to run Devstack, my local.conf looks like this

[[local|localrc]]
ADMIN_PASSWORD=secret
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD

When I run ./stack.sh everything works as expected. I am able to access horizon, create instances, etc. Before shutting down the machine I run ./unstack.sh. When I later start the machine again I start devstack by using screen -c stack-screenrc. I am able to access horion, however when I try to log in I get an invalid credentials error. I looken in horizon screen and I saw the following errors

2017-02-18 16:51:18.687058 DEBUG:keystoneauth.identity.v3.base:Making authentication request to http://192.168.2.102/identity/v3/auth/tokens
2017-02-18 16:51:18.725239 DEBUG:keystoneauth.session:Request returned failure status: 404
2017-02-18 16:51:18.725569 Login failed for user "demo", remote address 192.168.2.101.

If I run ./stack.sh again everything works until reboot/shutdown. Am I doing somehting wrong wrong when starting devstack after reboot? I don't wan't to run ./stack.sh evrytime since it takes a long time to complete and I don't want to wipe my data.