Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

asked 2014-01-08 12:41:42 -0500

mili gravatar image

Neutron OVS ERROR on controller

Hi,

I just made a small change to my configuration. what i did was deleted all the keystone endpoints and added them in again just a diffrent public url. what happend was everything was working expect I was getting the below error on the controller node in the server-log:

2014-01-08 18:38:47.491 1430 DEBUG routes.middleware [-] Match dict: {'action': u'index', 'controller': <wsgify at="" 46817488="" wrapping="" <function="" resource="" at="" 0x2ca0320="">>, 'format': u'json'} __call__ /usr/lib/python2.7/dist-packages/routes/middleware.py:103 2014-01-08 18:38:47.510 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:allowed_address_pairs not found. Assuming no authZ check is defined for allowed_address_pairs _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143 2014-01-08 18:38:47.511 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:fixed_ips not found. Assuming no authZ check is defined for fixed_ips _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143 2014-01-08 18:38:47.511 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:mac_address not found. Assuming no authZ check is defined for mac_address _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143 2014-01-08 18:38:48.068 1430 DEBUG neutron.openstack.common.rpc.amqp [-] received {u'_context_roles': [u'admin'], u'_context_read_deleted': u'no', u'_context_tenant_id': None, u'args': {u'agent_state': {u'agent_state': {u'topic': u'N/A', u'binary': u'neutron-openvswitch-agent', u'host': u'compute3', u'agent_type': u'Open vSwitch agent', u'configurations': {u'tunnel_types': [u'gre'], u'tunneling_ip': u'172.16.10.13', u'bridge_mappings': {}, u'l2_population': False, u'devices': 0}}}, u'time': u'2014-01-08T18:38:48.086117'}, u'namespace': None, u'_unique_id': u'ba4b9da0c28348cd9b66873644bbc1c0', u'_context_is_admin': True, u'version': u'1.0', u'_context_project_id': None, u'_context_timestamp': u'2014-01-08 17:09:37.986970', u'_context_user_id': None, u'method': u'report_state'} _safe_log /usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/common.py:276

And in the openvswitch-agent.log on the controller node: 2014-01-08 18:40:24.666 19977 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Tunneling cannot be enabled without a valid local_ip. Agent terminated!

I changed the endpoint back to what it was but still the same error.

any idea? help is really appreciated as these logs are more than 3 times / sec.

Cheers

click to hide/show revision 2
No.2 Revision

Neutron OVS ERROR on controller

Hi,

I just made a small change to my configuration. what i did was deleted all the keystone endpoints and added them in again just a diffrent public url. what happend was everything was working expect I was getting the below error on the controller node in the server-log:

2014-01-08 18:38:47.491 1430 DEBUG routes.middleware [-] Match dict: {'action': u'index', 'controller': <wsgify at="" 46817488="" wrapping="" <function="" resource="" at="" 0x2ca0320="">>, at 46817488 wrapping <function resource at 0x2ca0320>>, 'format': u'json'} __call__ /usr/lib/python2.7/dist-packages/routes/middleware.py:103
2014-01-08 18:38:47.510 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:allowed_address_pairs not found. Assuming no authZ check is defined for allowed_address_pairs _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143
2014-01-08 18:38:47.511 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:fixed_ips not found. Assuming no authZ check is defined for fixed_ips _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143
2014-01-08 18:38:47.511 1430 DEBUG neutron.api.v2.base [-] Policy rule:get_port:mac_address not found. Assuming no authZ check is defined for mac_address _is_visible /usr/lib/python2.7/dist-packages/neutron/api/v2/base.py:143
2014-01-08 18:38:48.068 1430 DEBUG neutron.openstack.common.rpc.amqp [-] received {u'_context_roles': [u'admin'], u'_context_read_deleted': u'no', u'_context_tenant_id': None, u'args': {u'agent_state': {u'agent_state': {u'topic': u'N/A', u'binary': u'neutron-openvswitch-agent', u'host': u'compute3', u'agent_type': u'Open vSwitch agent', u'configurations': {u'tunnel_types': [u'gre'], u'tunneling_ip': u'172.16.10.13', u'bridge_mappings': {}, u'l2_population': False, u'devices': 0}}}, u'time': u'2014-01-08T18:38:48.086117'}, u'namespace': None, u'_unique_id': u'ba4b9da0c28348cd9b66873644bbc1c0', u'_context_is_admin': True, u'version': u'1.0', u'_context_project_id': None, u'_context_timestamp': u'2014-01-08 17:09:37.986970', u'_context_user_id': None, u'method': u'report_state'} _safe_log /usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/common.py:276

/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/common.py:276

And in the openvswitch-agent.log on the controller node: node:

2014-01-08 18:40:24.666 19977 ERROR neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Tunneling cannot be enabled without a valid local_ip. Agent terminated!

terminated!

I changed the endpoint back to what it was but still the same error.

any idea? help is really appreciated as these logs are more than 3 times / sec.

Cheers