Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Packstack installation always gives error of mariadb-server being obsolete and removed by mysql-community-server which is already installed

Hello, I am installing OpenStack mitaka (tried with Newton also) over Centos 7 using Packstack. It is a Single node installation. Have used following commands to install -

yum install -y centos-release-openstack-mitaka yum install -y openstack-packstack packstack --answer-file /root/answers.txt

But even after updating centos, reinstalling mysql many times, I am getting same error -

Copying Puppet modules and manifests                 [ DONE ]
Applying 10.10.15.10_controller.pp
10.10.15.10_controller.pp:                        [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.10.15.10_controller.pp
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install mariadb-server-galera' returned 1: Package 3:mariadb-server-10.1.18-3.el7.x86_64 is obsoleted by mysql-community-server-5.7.17-1.el7.x86_64 which is already installed
You will find full trace in log /var/tmp/packstack/20170131-212844-VEGrWK/manifests/10.10.15.10_controller.pp.log

I have already removed mysql-community-server and tried it, installed mysql-community-server again and tried it, even uninstalled mysql-community-server and installed mariadb-server-galera (which inturn installed mysql-community-server only) but none of these worked.

Any clue/help would be appreciated.