Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Openstack Neutron Instances not getting IP addresses

I have built a test Openstack Environment, identical to the Newton install guide:

http://docs.openstack.org/newton/install-guide-rdo/

My Cirros images only get assigned a DHCP address when the CentOS7 firewall is disabled on both Controller and Compute.

NICs on both Controller and Compute are in the public zone. I have issued the following commands on both for DHCP ports:

firewall-cmd --zone=public --add-port=67/udp --permanent
firewall-cmd --zone=public --add-port=68/udp --permanent
firewall-cmd --reload

In addition, I have also issued the following commands on Controller and Compute:

firewall-cmd --zone=public --add-service=dhcp --permanent
firewall-cmd --reload

Openstack Neutron Instances not getting IP addresses

I have built a test Openstack Environment, identical to the Newton install guide:

http://docs.openstack.org/newton/install-guide-rdo/

My Cirros images only get assigned a DHCP address when the CentOS7 firewall is disabled on both Controller and Compute.

NICs on both Controller and Compute are in the public zone. I have issued the following commands on both for DHCP ports:

firewall-cmd --zone=public --add-port=67/udp --permanent
firewall-cmd --zone=public --add-port=68/udp --permanent
firewall-cmd --reload

In addition, I have also issued the following commands on Controller and Compute:

firewall-cmd --zone=public --add-service=dhcp --permanent
firewall-cmd --reload