Revision history [back]

click to hide/show revision 1
initial version

No serial console logs in dashboard on arm64 platform after instance creation

Hi,

I just installed the openstack using devstack with enabled serial console 'enable_service n-sproxy' service on Ubuntu 16.04LTS on arm64 platform(APM's mustang)

I have been created one instance with custom kernel and ramdisk(converted to amazon images). It is showing 'running' on dashboard but nothing is displayed on dashboard's console. status: Closed is displaying on bottom left corner.

I tried to access through

virsh console instance-00000001 --devname serial1

, it is just blinking but nothing it is showing.

I tried to install the same images with virt-install command, it is booting properly.

Below is instance console log

cat /var/log/libvirt/qemu/instance-00000001.log

    LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-system-aarch64 -name instance-00000001 -S -machine virt,accel=kvm,usb=off -cpu host -m 1024 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid e65360f5-ec88-42d3-8b87-761241e9b892 -nographic -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-instance-00000001/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-shutdown -boot strict=on -kernel /opt/stack/data/nova/instances/e65360f5-ec88-42d3-8b87-761241e9b892/kernel -initrd /opt/stack/data/nova/instances/e65360f5-ec88-42d3-8b87-761241e9b892/ramdisk -append 'root=/dev/vda console=tty0 console=ttyS0' -device i82801b11-bridge,id=pci.1,bus=pcie.0,addr=0x1 -device pci-bridge,chassis_nr=2,id=pci.2,bus=pci.1,addr=0x1 -usb -drive file=/dev/disk/by-path/ip-10.48.13.31:3260-iscsi-iqn.2010-10.org.openstack:volume-fbf8d86c-8a87-46d3-be35-6d848c20d6ed-lun-1,format=raw,if=none,id=drive-virtio-disk0,serial=fbf8d86c-8a87-46d3-be35-6d848c20d6ed,cache=none,aio=native -device virtio-blk-device,scsi=off,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=25,id=hostnet0 -device virtio-net-device,netdev=hostnet0,id=net0,mac=fa:16:3e:96:b9:3d -serial tcp:127.0.0.1:10000,server,nowait -serial pty -device virtio-balloon-device,id=balloon0 -msg timestamp=on

    **Domain id=9 is tainted: host-cpu**

    char device redirected to /dev/pts/27 (label serial1)

Apart from this suspicious log, i didn't found anything.

Is this taint will create a problem? If yes, kindly provide me work around to achieve the same

Note: I didn't get this taint while installing with virsh-install