Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Instance shows active but not booting

Running RDO Liberty and Newton on an AWS centos 7.0 HVM node. All-in-one via packstack

Instance launches, but does not go through the block device mapping phase. Quickly goes to active. A volume is created and can be seen via cinder command. The instance console says "Starting up..." I have also had nodes fail with PXE errors. Also failing to boot.

No console log at all for the instance. Horizon shows a single blank line. Nothing else. So it isn't booting.

I have tried two cirros images and a centos image - same error. CLI and horizon.

All openstack services show active and running via systemctl output

Few errors, only one that looks like it may matter is this: [root@ip-172-31-41-255 log(keystone_admin)]# grep -i error nova/nova-compute.log 2017-01-12 05:35:05.892 26936 ERROR nova.compute.manager [req-f7b2d76e-5367-4d68-b698-979fc4667b0c - - - - -] No compute node record for host ip-172-31-41-255

No libvirt.log or other errors The instances are just not finishing the launch.

Anyone have ideas where to look or what to fix?