Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

【help】Multiple possible networks found, use a Network ID to be more specific

I 'm testing openstack auto scaling function,but i was met a problem,when we upload template to create a stack, it failed! So i check heat log, the error log is :Multiple possible networks found, use a Network ID to be more specific. could anybody tell me how to solve it?

template as bellow:

HeatTemplateFormatVersion: '2012-12-12' Description: Creates an autoscaling wordpress application using Ceilometer. Parameters: KeyName: Description: Name of an existing EC2 KeyPair to enable SSH access to the instances Type: String InstanceType: Description: WebServer EC2 instance type Type: String Default: m1.small AllowedValues: [m1.tiny, m1.small, m1.medium, m1.large, m1.xlarge] ConstraintDescription: must be a valid EC2 instance type. ImageId: Description: the name or uuid of the image in glance Type: String Default: ba8b2f35-b539-40b0-a620-e5ac2fde3fa6 Resources:

WebServerGroup: Type: AWS::AutoScaling::AutoScalingGroup Properties: AvailabilityZones: {'Fn::GetAZs': ''} LaunchConfigurationName: {Ref: LaunchConfig} MinSize: '1' MaxSize: '3' WebServerScaleUpPolicy: Type: AWS::AutoScaling::ScalingPolicy Properties: AdjustmentType: ChangeInCapacity AutoScalingGroupName: {Ref: WebServerGroup} Cooldown: '60' ScalingAdjustment: '1' WebServerScaleDownPolicy: Type: AWS::AutoScaling::ScalingPolicy Properties: AdjustmentType: ChangeInCapacity AutoScalingGroupName: {Ref: WebServerGroup} Cooldown: '60' ScalingAdjustment: '-1' CPUAlarmHigh: Type: OS::Ceilometer::Alarm Properties: description: Scale-up if the average CPU > 50% for 1 minute meter_name: cpu_util statistic: avg period: '60' evaluation_periods: '1' threshold: '50' alarm_actions: - {"Fn::GetAtt": [WebServerScaleUpPolicy, AlarmUrl]} matching_metadata: {'metadata.user_metadata.groupname': {Ref: 'WebServerGroup'}} comparison_operator: gt CPUAlarmLow: Type: OS::Ceilometer::Alarm Properties: description: Scale-down if the average CPU < 15% for 1 minute meter_name: cpu_util statistic: avg period: '60' evaluation_periods: '1' threshold: '15' alarm_actions: - {"Fn::GetAtt": [WebServerScaleDownPolicy, AlarmUrl]} matching_metadata: {'metadata.user_metadata.groupname': {Ref: 'WebServerGroup'}} comparison_operator: lt LaunchConfig: Type: AWS::AutoScaling::LaunchConfiguration Properties: ImageId: {Ref: ImageId} InstanceType: {Ref: InstanceType} KeyName: {Ref: KeyName}

Outputs: URL: Description: The URL of the website Value: Fn::Replace: - IpAddress: {'Fn::GetAtt': [ElasticLoadBalancer, DNSName]} - http://IpAddress/wordpress

【help】Multiple Multiple possible networks found, use a Network ID to be more specific

I 'm testing openstack auto scaling function,but i was met a problem,when we upload template to create a stack, it failed! So i check heat log, the error log is :Multiple possible networks found, use a Network ID to be more specific. could anybody tell me how to solve it?

template as bellow:

HeatTemplateFormatVersion: '2012-12-12'
Description: Creates an autoscaling wordpress application using Ceilometer.
Parameters:
  KeyName:
    Description: Name of an existing EC2 KeyPair to enable SSH access to the instances
    Type: String
  InstanceType:
    Description: WebServer EC2 instance type
    Type: String
    Default: m1.small
    AllowedValues: [m1.tiny, m1.small, m1.medium, m1.large, m1.xlarge]
    ConstraintDescription: must be a valid EC2 instance type.
  ImageId:
    Description: the name or uuid of the image in glance
    Type: String
    Default: ba8b2f35-b539-40b0-a620-e5ac2fde3fa6
Resources:

Resources: WebServerGroup: Type: AWS::AutoScaling::AutoScalingGroup Properties: AvailabilityZones: {'Fn::GetAZs': ''} LaunchConfigurationName: {Ref: LaunchConfig} MinSize: '1' MaxSize: '3' WebServerScaleUpPolicy: Type: AWS::AutoScaling::ScalingPolicy Properties: AdjustmentType: ChangeInCapacity AutoScalingGroupName: {Ref: WebServerGroup} Cooldown: '60' ScalingAdjustment: '1' WebServerScaleDownPolicy: Type: AWS::AutoScaling::ScalingPolicy Properties: AdjustmentType: ChangeInCapacity AutoScalingGroupName: {Ref: WebServerGroup} Cooldown: '60' ScalingAdjustment: '-1' CPUAlarmHigh: Type: OS::Ceilometer::Alarm Properties: description: Scale-up if the average CPU > 50% for 1 minute meter_name: cpu_util statistic: avg period: '60' evaluation_periods: '1' threshold: '50' alarm_actions: - {"Fn::GetAtt": [WebServerScaleUpPolicy, AlarmUrl]} matching_metadata: {'metadata.user_metadata.groupname': {Ref: 'WebServerGroup'}} comparison_operator: gt CPUAlarmLow: Type: OS::Ceilometer::Alarm Properties: description: Scale-down if the average CPU < 15% for 1 minute meter_name: cpu_util statistic: avg period: '60' evaluation_periods: '1' threshold: '15' alarm_actions: - {"Fn::GetAtt": [WebServerScaleDownPolicy, AlarmUrl]} matching_metadata: {'metadata.user_metadata.groupname': {Ref: 'WebServerGroup'}} comparison_operator: lt LaunchConfig: Type: AWS::AutoScaling::LaunchConfiguration Properties: ImageId: {Ref: ImageId} InstanceType: {Ref: InstanceType} KeyName: {Ref: KeyName}

KeyName} Outputs: URL: Description: The URL of the website Value: Fn::Replace: - IpAddress: {'Fn::GetAtt': [ElasticLoadBalancer, DNSName]} - http://IpAddress/wordpress

http://IpAddress/wordpress