Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

DevStack Newton openstack client - barbican oslo.utils related errors

Hello Everyone,

I'm using Ubuntu 16.04 to build Newton based DevStack single VM installation. DevStack is working fine, but running the openstack list command returns error messages like this one...

Could not load EntryPoint.parse('secret_container_create = barbicanclient.barbican_cli.containers:CreateContainer')
Could not load EntryPoint.parse('secret_container_delete = barbicanclient.barbican_cli.containers:DeleteContainer')
Could not load EntryPoint.parse('secret_container_get = barbicanclient.barbican_cli.containers:GetContainer')
Could not load EntryPoint.parse('secret_container_list = barbicanclient.barbican_cli.containers:ListContainer')
...

Running the openstack client with --debug option, I've discovered the following conflict:

VersionConflict: (oslo.utils 3.16.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('oslo.utils>=3.18.0'))

Changing the oslo.utils version from 3.16.0 to 3.18.0 in the requirements/general-requirements.txt file, and rebuilding the stack produced different kind of erros.

I've also tried to remove barbican from my configuration, but openstack client still reports an error. Is there any way to get this sorted out?

Thank you in advance!