Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

OVS bridge br-ex to Ethernet loses network connectivity

Hey all,

So trying to follow a guide in regards to setting up an Openstack instance. But I keep running into issues when trying to bridge the NIC to the OVS br-ex.

So my ifcfg-enp1s0f0 looks like this

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="enp1s0f0"
DEVICE="enp1s0f0"
ONBOOT="yes"
TYPE=”OVSPort”
DEVICETYPE=”ovs”
OVS_BRIDGE=”br-ex”

the ifcfg-br-ex

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="br-ex"
UUID="not-sure-if-this-is-supposed-to-be-secret"
DEVICE="br-ex"
ONBOOT="yes"
IPADDR="172.16.2.99"
PREFIX="24"
GATEWAY="172.16.2.1"
DNS1="127.0.0.1"
DNS2="172.16.2.1"
DNS3="8.8.8.8"
IPV6_PEERDNS="no"
IPV6_PEERROUTES="no"
IPV6_PRIVACY="no"

Once I run

systemctl restart network.service

We lose connection to the box and only have terminal access..

If anyone could help it'd be much appreciated given the server room is freezing cold and I hate having to sit in there debugging :'(

From some cold debugging... Running ip a from the terminal results in

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ec4:7aff:fed2:9c36/64 scope link
        valid_lft forever preferred_lft forever
3: enp1s0f1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
4: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 96:bb:b2:19:41:8f brd ff:ff:ff:ff:ff:ff
5: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 32:ee:d8:83:97:44 brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.99/24 brd 172.16.2.255 scope global br-ex
       valid_lft forever preferred_lft forever
    inet6 fe80::30ee:d8ff:fe83:9744/64 scope link
       valid_lft forever preferred_lft forever
6: qg-88f6b26c-e9: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether fe:0b:01:99:6a:d0 brd ff:ff:ff:ff:ff:ff
7: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 66:4a:48:84:6e:46 brd ff:ff:ff:ff:ff:ff
8: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 2a:78:f1:24:b2:4b brd ff:ff:ff:ff:ff:ff

I've also tried adding

NM_CONTROLLED=no

to both files and also added

defroute=no

to the enp1s0f0 interface . Still no joy each time I lose outbound connections

OVS bridge br-ex to Ethernet loses network connectivity

Hey all,

So trying to follow a guide in regards to setting up an Openstack instance. But I keep running into issues when trying to bridge the NIC to the OVS br-ex.

So my ifcfg-enp1s0f0 looks like this

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="enp1s0f0"
DEVICE="enp1s0f0"
ONBOOT="yes"
TYPE=”OVSPort”
DEVICETYPE=”ovs”
OVS_BRIDGE=”br-ex”

the ifcfg-br-ex

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="br-ex"
UUID="not-sure-if-this-is-supposed-to-be-secret"
DEVICE="br-ex"
ONBOOT="yes"
IPADDR="172.16.2.99"
PREFIX="24"
GATEWAY="172.16.2.1"
DNS1="127.0.0.1"
DNS2="172.16.2.1"
DNS3="8.8.8.8"
IPV6_PEERDNS="no"
IPV6_PEERROUTES="no"
IPV6_PRIVACY="no"

Once I run

systemctl restart network.service

We lose connection to the box and only have terminal access..

If anyone could help it'd be much appreciated given the server room is freezing cold and I hate having to sit in there debugging :'(

From some cold debugging... Running ip a from the terminal results in

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ec4:7aff:fed2:9c36/64 scope link
        valid_lft forever preferred_lft forever
3: enp1s0f1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
4: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 96:bb:b2:19:41:8f brd ff:ff:ff:ff:ff:ff
5: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 32:ee:d8:83:97:44 brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.99/24 brd 172.16.2.255 scope global br-ex
       valid_lft forever preferred_lft forever
    inet6 fe80::30ee:d8ff:fe83:9744/64 scope link
       valid_lft forever preferred_lft forever
6: qg-88f6b26c-e9: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether fe:0b:01:99:6a:d0 brd ff:ff:ff:ff:ff:ff
7: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 66:4a:48:84:6e:46 brd ff:ff:ff:ff:ff:ff
8: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 2a:78:f1:24:b2:4b brd ff:ff:ff:ff:ff:ff

I've also tried adding

NM_CONTROLLED=no

to both files and also added

defroute=no

to the enp1s0f0 interface . Still no joy each time I lose outbound connections

Futher debugging is showing this once the OVS bridge is activated

cat /tmp/ovs-vsctl_show.output
30032ac4-00af-4311-a01e-62902d870987
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "tap9d31141d-ec"
            tag: 1
            Interface "tap9d31141d-ec"
                type: internal
        Port "qr-e4c8a4c1-12"
            tag: 1
            Interface "qr-e4c8a4c1-12"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Port "qg-88f6b26c-e9"
            Interface "qg-88f6b26c-e9"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.5.0"

OVS bridge br-ex to Ethernet loses network connectivity

Hey all,

So trying to follow a guide in regards to setting up an Openstack instance. But I keep running into issues when trying to bridge the NIC to the OVS br-ex.

So my ifcfg-enp1s0f0 looks like this

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="enp1s0f0"
DEVICE="enp1s0f0"
ONBOOT="yes"
TYPE=”OVSPort”
DEVICETYPE=”ovs”
OVS_BRIDGE=”br-ex”
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE="br-ex"
NM_CONTROLLED="no"

the ifcfg-br-ex

TYPE="Ethernet"
BOOTPROTO="none"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="no"
IPV6INIT="no"
IPV6_AUTOCONF="no"
IPV6_DEFROUTE="no"
IPV6_FAILURE_FATAL="no"
NAME="br-ex"
UUID="not-sure-if-this-is-supposed-to-be-secret"
DEVICE="br-ex"
ONBOOT="yes"
IPADDR="172.16.2.99"
PREFIX="24"
GATEWAY="172.16.2.1"
DNS1="127.0.0.1"
DNS2="172.16.2.1"
DNS3="8.8.8.8"
IPV6_PEERDNS="no"
IPV6_PEERROUTES="no"
IPV6_PRIVACY="no"

Once I run

systemctl restart network.service

We lose connection to the box and only have terminal access..

If anyone could help it'd be much appreciated given the server room is freezing cold and I hate having to sit in there debugging :'(

From some cold debugging... Running ip a from the terminal results in

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
     link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
     inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp1s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    inet6 fe80::ec4:7aff:fed2:9c36/64 scope link
        valid_lft forever preferred_lft forever
3: enp1s0f1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
4: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 96:bb:b2:19:41:8f brd ff:ff:ff:ff:ff:ff
5: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 32:ee:d8:83:97:44 brd ff:ff:ff:ff:ff:ff
    inet 172.16.2.99/24 brd 172.16.2.255 scope global br-ex
       valid_lft forever preferred_lft forever
    inet6 fe80::30ee:d8ff:fe83:9744/64 scope link
       valid_lft forever preferred_lft forever
6: qg-88f6b26c-e9: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether fe:0b:01:99:6a:d0 brd ff:ff:ff:ff:ff:ff
7: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 66:4a:48:84:6e:46 brd ff:ff:ff:ff:ff:ff
8: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 2a:78:f1:24:b2:4b brd ff:ff:ff:ff:ff:ff

I've also tried adding

NM_CONTROLLED=no

to both files and also added

defroute=no

to the enp1s0f0 interface . Still no joy each time I lose outbound connections

Futher debugging is showing this once the OVS bridge is activated

cat /tmp/ovs-vsctl_show.output
30032ac4-00af-4311-a01e-62902d870987
    Manager "ptcp:6640:127.0.0.1"
        is_connected: true
    Bridge br-int
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port "tap9d31141d-ec"
            tag: 1
            Interface "tap9d31141d-ec"
                type: internal
        Port "qr-e4c8a4c1-12"
            tag: 1
            Interface "qr-e4c8a4c1-12"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Port "qg-88f6b26c-e9"
            Interface "qg-88f6b26c-e9"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-tun
        Controller "tcp:127.0.0.1:6633"
            is_connected: true
        fail_mode: secure
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.5.0"