Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

sahara cluster(instance) launch fail

Hi. I'm trying to launch a cluster using sahara and it keeps failing.

2016-12-15 19:39:23.102 2785 WARNING sahara.service.heat.heat_engine [req-e3f6db45-87cc-491f-b6dd-031311c022a1 6abfef77e9984fc58bb5decc566d12c2 fda14487a68f436da7b55fe218798ea2 - - -] [instance: none, cluster: 28349417-acef-4b24-bc26-b77a6bd54cf9] Cluster creation rollback (reason: Heat stack failed with status Resource CREATE failed: NotFound: resources.vanilla-default-worker.resources[0].resources.floating_ip: Floating IP pool not found. (HTTP 404) (Request-ID: req-d7f8fd82-2b89-41b8-8720-30ee8d1097c6)

I think this is where it's going bad. this is my neutron net-list:

+--------------------------------------+------------------------+-----------------------------------------------------+
| id                                   | name                   | subnets                                             |
+--------------------------------------+------------------------+-----------------------------------------------------+
| cf2eca34-646e-432e-8271-ccfe290ca08d | test-net               | 3b3f9797-25ad-4054-a78c-acb8b14176d1 172.168.1.0/24 |
| c2fc1c68-6006-410a-bd92-0ba7708aa8d9 | manila_service_network | b72b952e-89ce-4c2c-a985-5191cf7c3f0e 10.254.0.0/28  |
| ad9301d1-8c5e-4e53-b8ec-5a054958b1b9 | external               | 539d3144-3f70-4b11-9db5-1964336677fb 192.168.0.0/24 |
+--------------------------------------+------------------------+-----------------------------------------------------+

I attached all nodes to test-net, and made cluster networking with test-net. I have no problem launching other instances using this network and they seem to work fine. I tried to set all nodes with external network and made cluster networking with external network, it passes this phase but it shows issues with portbinding. So I should use this test-net, which is meant to be private network in cloud, but I don't know why it says that Floating IP pool is not found. Where should I be looking at to solve this issue?

sahara cluster(instance) launch fail

Hi. I'm trying to launch a cluster using sahara and it keeps failing.

2016-12-15 19:39:23.102 2785 WARNING sahara.service.heat.heat_engine [req-e3f6db45-87cc-491f-b6dd-031311c022a1 6abfef77e9984fc58bb5decc566d12c2 fda14487a68f436da7b55fe218798ea2 - - -] [instance: none, cluster: 28349417-acef-4b24-bc26-b77a6bd54cf9] Cluster creation rollback (reason: Heat stack failed with status Resource CREATE failed: NotFound: resources.vanilla-default-worker.resources[0].resources.floating_ip: Floating IP pool not found. (HTTP 404) (Request-ID: req-d7f8fd82-2b89-41b8-8720-30ee8d1097c6)

I think this is where it's going bad. this is my neutron net-list:

+--------------------------------------+------------------------+-----------------------------------------------------+
| id                                   | name                   | subnets                                             |
+--------------------------------------+------------------------+-----------------------------------------------------+
| cf2eca34-646e-432e-8271-ccfe290ca08d | test-net               | 3b3f9797-25ad-4054-a78c-acb8b14176d1 172.168.1.0/24 |
| c2fc1c68-6006-410a-bd92-0ba7708aa8d9 | manila_service_network | b72b952e-89ce-4c2c-a985-5191cf7c3f0e 10.254.0.0/28  |
| ad9301d1-8c5e-4e53-b8ec-5a054958b1b9 | external               | 539d3144-3f70-4b11-9db5-1964336677fb 192.168.0.0/24 |
+--------------------------------------+------------------------+-----------------------------------------------------+

I attached all nodes to test-net, and made cluster networking with test-net. I have no problem launching other instances using this network and they seem to work fine. I tried to set all nodes with external network and made cluster networking with external network, it passes this phase but it shows issues with portbinding. So I should use this test-net, which is meant to be private network in cloud, but I don't know why it says that Floating IP pool is not found. Where should I be looking at to solve this issue?