Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

[Cinder] CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11.

I followed the installation guide http://docs.openstack.org/mitaka/install-guide-rdo/ and got everything working as described except from cinder.

root [at] storage:~# tail -f /var/log/cinder/cinder-volume.log

2016-11-04 15:45:16.119 7260 WARNING oslo_reports.guru_meditation_report [-] Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in aure release, so please use SIGUSR2 to generate reports. 2016-11-04 15:45:16.403 7260 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt 2016-11-04 15:45:16.531 7260 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt 2016-11-04 15:45:16.625 7260 WARNING py.warnings [req-b26e5a8d-0736-4568-a537-3a04778e5d14 - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuratoption(s) ['use_tpool'] not supported exception.NotSupportedWarning

2016-11-04 15:45:16.822 7260 INFO cinder.rpc [req-b26e5a8d-0736-4568-a537-3a04778e5d14 - - - - -] Automatically selected cinder-scheduler objects version 1.11 as minimum service version. 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume [req-b26e5a8d-0736-4568-a537-3a04778e5d14 - - - - -] Volume service storage0 [at] lv failed to start. 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume Traceback (most recent call last): 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/cmd/volume.py", line 81, in main 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume binary='cinder-volume') 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 268, in create 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume service_name=service_name) 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/service.py", line 150, in __init__ 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume args, *kwargs) 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/volume/manager.py", line 235, in __init__ 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume args, *kwargs) 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/manager.py", line 156, in __init__ 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume self.scheduler_rpcapi = scheduler_rpcapi.SchedulerAPI() 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/rpc.py", line 188, in __init__ 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume serializer = base.CinderObjectSerializer(obj_version_cap) 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume File "/usr/lib/python2.7/dist-packages/cinder/objects/base.py", line 412, in __init__ 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume raise exception.CappedVersionUnknown(version=version_cap) 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume CappedVersionUnknown: Unrecoverable Error: Versioned Objects in DB are capped to unknown version 1.11. 2016-11-04 15:45:16.824 7260 ERROR cinder.cmd.volume 2016-11-04 15:45:16.832 7260 ERROR cinder.cmd.volume [req-b26e5a8d-0736-4568-a537-3a04778e5d14 - - - - -] No volume service(s) started successfully, terminating. 2016-11-04 15:45:18.531 7281 WARNING oslo_reports.guru_meditation_report [-] Guru mediation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in aure release, so please use SIGUSR2 to generate reports. 2016-11-04 15:45:18.772 7281 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt 2016-11-04 15:45:18.893 7281 INFO root [-] Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt 2016-11-04 15:45:18.990 7281 WARNING py.warnings [req-273a0fd1-2617-4251-9340-a69e8dbf5b86 - - - - -] /usr/lib/python2.7/dist-packages/oslo_db/sqlalchemy/enginefacade.py:241: NotSupportedWarning: Configuratoption(s) ['use_tpool'] not supported exception.NotSupportedWarning

I have three servers 1 controller 1 compute and 1 block storage.

the output of vgs and pvs as following : pvs PV VG Fmt Attr PSize PFree /dev/sda2 centos lvm2 a-- 507.75g 0 /dev/sdb cinder-volumes lvm2 a-- 1.09t 1.09t

vgs VG #PV #LV #SN Attr VSize VFree centos 1 2 0 wz--n- 507.75g 0 cinder-volumes 1 0 0 wz--n- 1.09t 1.09t

please your support will be appreciated as I am new to openstack. Thank you.